[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Paplay or Aplay Confusion

From: Steve Holmes
Subject: Paplay or Aplay Confusion
Date: Sun, 15 Aug 2010 19:18:28 -0700

Anybody try recent git versions of speechd with the Cepstral swift
speech system?  I posted this message last week but haven't heard
anything on it.  See the repeat below to learn more.  Basically, with
the default AudioOutputMethod options, it tries to launch the wrong
player if the system doesn't have pulse installed.

On Sat, Aug 14, 2010 at 11:07:10AM -0700, Steve Holmes wrote:
> I think this bug came up in the past but thought it solved by now.
> What is happening with the swift-generic module is the synth command
> line substitutes paplay or aplay depending on whether pulseaudio or
> alsa is being used.  In my speechd.conf, the DefaultAudioMethod was
> set to "pulsa,alsa".  I presently do not have pulse installed on my
> system.  For whatever reason, speech dispatcher still tried to use
> paplay to play the generated wav file.  When I removed pulse from the
> DefaultAudioMethod string, then aplay was properly substituted and
> swift-generic worked again.  I'm experiencing this with the latest git
> pull of Aug 13th.  I thought this was working before with the original
> speechd.conf so I'm wondering if a recent change affected the player
> selection and autio output methods.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]