[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Speechd] speechd-el - what am I doing wrong

From: Tim Cross
Subject: Re: [Speechd] speechd-el - what am I doing wrong
Date: Fri, 23 Aug 2019 10:12:02 +1000
User-agent: mu4e 1.3.4; emacs 27.0.50

Thanks Milan.

another priority task has just landed on my desk, so I'll have to park
this temporarily for a week or so. When I get back to it, I'll send
through the backtrace for the backspace error I've been getting. I'll
also try your suggestions for identifying what is causing the speech
rate to change. Thanks for your help.


Milan Zamazal <address@hidden> writes:

>>>>>> "TC" == Tim Cross <address@hidden> writes:
>     TC> I worked it out (I think). It was to do with how mu4e 
> generates/displays
>     TC> the line - it isn't really a line, but a list of fields. Anyway, I 
> went
>     TC> a step further to make the output a little more 'friendly'. In case
>     TC> anyone finds it useful, I've copied it below.
> Hi Tim, nice to hear you managed to disentangle it, good job!
>     TC> The only remaining and annoying issue I have is that for some reason, 
> my
>     TC> setting for speech rate keeps reverting to a much slower rate. Can't
>     TC> seem to track down where this is happening. Have set my default speech
>     TC> dispatcher rate (globally and locally), speech dispatcher client rate
>     TC> and also in speechd-speak-hook, but rate seems to revert to a much
>     TC> slower rate at what seems fairly random points. Seems to be worse with
>     TC> IBM ViaVoice than espeak-ng, which makes me think it is the TTS dying
>     TC> and being re-started, but don't know why it isn't being restarted with
>     TC> the default rates I have set.
> Does Speech Dispatcher log (with verbosity level 4) reveal something?
> Are there any TTS restarts reported there?  Or either inappropriate or
> missing rate changes?
>     TC> I still have a couple of other issues I'm trying to fix. In 
> particular,
>     TC> there is a bug relating to speechd-el and either flycheck or eldoc 
> (not
>     TC> narrowed it down yet) which prevents backspace from working (args out 
> of
>     TC> range error). I haven't really tried to track it down yet, but plan 
> to.
> Backspace works fine for me with flycheck and eldoc modes enabled.  Do
> you have a backtrace of the error?
>     TC> Apart from those two issues, all seems to work OK.
> Excellent. :-)

Tim Cross

reply via email to

[Prev in Thread] Current Thread [Next in Thread]