[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Synaptic-devel] "Please contact the author of this software if this

From: Michael Vogt
Subject: Re: [Synaptic-devel] "Please contact the author of this software if this messageis diplayed"
Date: Thu, 15 Apr 2004 13:36:11 +0200
User-agent: Mutt/

On Wed, Apr 14, 2004 at 09:46:33PM -0400, Philip Miller wrote:
> >Thanks. What kind of kernel do you run? How often did this happen? Is
> >it reproducable? 
> $ uname -a
> Linux phil 2.6.5+phil1 #1 Sun Apr 4 14:16:16 EDT 2004 i686 GNU/Linux
> Locally built, but no patches, just the vanilla source.
> When I run it again from apt-watch, when it shows there are upgrades, I 
> receive the same error on the first attempt at 'Apply'ing, and then it 
> works correctly on the second, as before.

Thanks a lot. The apt-watch hint helped a lot. I can reproduce the
problem here and it looks like it's some issue with apt-watch and
libzvt (the library we use for terminal output). I have version of
synaptic that builds against a different terminal widget (vte from
latest cvs) and the problem does not occur then. 

It looks like it's some really weird issue deep inside the terminal
handling. For those on the list that may want to help I attached a
strace of the child process. It looks like the problem is caused by
this lines:

[pid 31638] access("/var/lib/dpkg", W_OK) = 0
[pid 31638] open("/var/lib/dpkg/lock",O_RDWR|O_CREAT|O_TRUNC|O_LARGEFILE, 0660) 
= 0
[pid 31638] fcntl64(0, F_SETLK64, {type=F_WRLCK, whence=SEEK_SET,start=0, 
len=0}, 0xbffff770) = -1 EAGAIN (Resource temporarily unavailable)

The real question of course is, what the root of the problem is :/
The return value of open looks wrong too. It shouldn't be fd=0. And
there are some lines like "close(0)" before.

And interesstingly with vte the locking with fcntl64() seems to work
fine (it uses fd=3 which looks correct). 

So my guess for now is that zvt does something very wrong with the pty
handling. I'll try to nail down the execat problem.  

> Philip miller
Linux is not The Answer. Yes is the answer. Linux is The Question. - Neo

Attachment: bad-run.log.gz
Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]