[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Tramp hangs

From: Michael Albinus
Subject: Re: Tramp hangs
Date: Tue, 07 Apr 2020 19:59:45 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/28.0.50 (gnu/linux)

Ryan Chipman <address@hidden> writes:

Hi Ryan,

> I am having this issue with non-AWS hosts that aren't behind a vpn as
> well. To remove the VPN/AWS confounding variables, I've repeated my
> previous steps with a different host, and attached the log to this
> email. Hopefully this one is more helpful!

It is still the same, the ssh command does not return anything back to
Tramp. I have tried it from my local machine, and I get

--8<---------------cut here---------------start------------->8---
root@ Permission denied (publickey).
--8<---------------cut here---------------end--------------->8---

which is expected.

Hmm, without any output from the command I cannot analyze. Have you
tried to use an Emacs started as "emacs -Q"?

ANother idea might be to add "-vvv" to the ssh client. Look at variable
tramp-methods, entry "ssh", and add it to the  tramp-login-args entry as

> Best, Ryan

Best regards, Michael.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]