[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: tramp (; Showing directory listing from wrong host

From: Michael Albinus
Subject: Re: tramp (; Showing directory listing from wrong host
Date: Sat, 22 May 2021 21:17:02 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/28.0.50 (gnu/linux)

Jon Schewe <> writes:

Hi Jon,

>> I see that my load-path has ~/.emacs.d/elpa/tramp- in my load
>> path before /usr/share/emacs/26.3/lisp/net, so that should make the
>> new
>> version load rather than the old version.
>> However when I run emacs without "--no-init" I find that tramp-
>> version
>> is "" and I cannot open tramp paths.
> I found a clue here. I printed out "load-path" in my init file and and
> the end of my init file and it doesn't include the directories in
> ~/.emacs.d/elpa. However after emacs finishes loading I find the
> directories in ~/.emacs.d/elpa/ added to load-path.
> So it seems that emacs is adding to load-path after my init file.

You should have something like

   '(tramp ...

at the end of your .emacs. This does adapting the load-path.

> I suspect I have more reading to do on how loading is working in emacs
> these days.

The other problem is compilation of Tramp. Have you tried to open the
link I gave the last message? Alternatively, you could read the same in

If this fails, simply remove all *.elc files from that directory, and
start a new Emacs session. And I will interview you tomorrow, how to
improve that text :-)

Best regards, Michael.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]