[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: tramp (; Showing directory listing from wrong host

From: Jon Schewe
Subject: Re: tramp (; Showing directory listing from wrong host
Date: Sat, 22 May 2021 14:37:24 -0500
User-agent: Evolution 3.36.4-0ubuntu1

On Sat, 2021-05-22 at 21:17 +0200, Michael Albinus wrote:
> Jon Schewe <
> > writes:
> Hi Jon,
> > > I see that my load-path has ~/.emacs.d/elpa/tramp- in my
> > > load
> > > path before /usr/share/emacs/26.3/lisp/net, so that should make
> > > the
> > > new
> > > version load rather than the old version.
> > > 
> > > However when I run emacs without "--no-init" I find that tramp-
> > > version
> > > is "" and I cannot open tramp paths.
> > 
> > I found a clue here. I printed out "load-path" in my init file and
> > and
> > the end of my init file and it doesn't include the directories in
> > ~/.emacs.d/elpa. However after emacs finishes loading I find the
> > directories in ~/.emacs.d/elpa/ added to load-path.
> > So it seems that emacs is adding to load-path after my init file.
> You should have something like
> (custom-set-variables
>  '(package-selected-packages
>    '(tramp ...
> at the end of your .emacs. This does adapting the load-path.

I have this, although it's toward the top of my init file.
Looking back at the comments in my init file I am loading tramp
explicitly so that the tramp variables exist and I can set some
defaults. I have found that this is no longer a good idea (it's been
years since I first setup this config). I have modified the setting of
these variables to use eval-after-load and have removed the explicit
load-library call. Now things are behaving as they should.

> > I suspect I have more reading to do on how loading is working in
> > emacs
> > these days.
> The other problem is compilation of Tramp. Have you tried to open the
> link I gave the last message? Alternatively, you could read the same
> in
> ~/.emacs.d/elpa/tramp-

Yes, I tried the link and the suggestion to execute tramp-recompile-
elpa, which came back with function not found. This was probably due to
both versions of tramp trying to load due to my obsolete load-library
call. After not finding that very helpful I figured you meant that I
should be following the link to the manual and went through that.

> If this fails, simply remove all *.elc files from that directory, and
> start a new Emacs session. And I will interview you tomorrow, how to
> improve that text :-)

In the end the problem was not with the compiliation, but with the
explicit call to load-library.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]