[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [XForms] fl_set_font_name() and segmentation fault error

From: Max
Subject: Re: [XForms] fl_set_font_name() and segmentation fault error
Date: Wed, 21 Oct 2009 08:23:03 +0200
User-agent: KMail/1.12.1 (Linux/2.6.30-gentoo-r5; KDE/4.3.1; x86_64; ; )

Dear Jens,

I have tried (with the same results) both the stable version provided with my 
distribution (1.0.90 on Gentoo) and a vanilla version downloaded from savannah 

Running valgrind with the option --leak-check=full does not report any unfreed 
memory block, everything is cleaned before the program exists. On the other 
hand, I get a more useful error message from X:

X Error of failed request:  BadFont (invalid Font parameter)
  Major opcode of failed request:  46 (X_CloseFont)
  Resource id in failed request:  0x4c00008
  Serial number of failed request:  996
  Current serial number in output stream:  998

Does it give you additional hints about the problem?


On Tuesday 20 October 2009, Jens Thoms Toerring wrote:
>  Dear Max,
>  On Tue, Oct 20, 2009 at 05:10:49PM +0200, Max wrote:
>  > thank you for your prompt answer - unfortunately I am not allowed to
>  > give you the program, as it depends on third-part libraries I cannot
>  > redistribute. I have prepared a (very!) small example which shows the
>  > same behaviour as the big program.
>  Thanks, that's even better than the large program!
>  > I have just compiled it with the command
>  >
>  > gcc -Wall -g  test_xforms.c  -lforms
>  >
>  > Attached to the email you have also the output of valgrind, there there
>  > are some more info about where the error occurs (in the xforms libraries
>  > compiled with the debug flag).
>  When I run that program on my machine (also a 64-bit system that
>  seems to use the same version of the X11 library) I don't get a
>  segmentation fault. And the output of valgrind also shows some
>  informations about some memory blocks allocated by X11 and not
>  deallocated before the program exists...
>  One thing that comes to mind is that there could be a conflict
>  between header files, i.e. different versions of <forms.h>, being
>  installed and the wrong one for the version of the library you're
>  using getting picked up. Could you check if there's more than one
>  header file named forms.h installed on your machine in the paths
>  in which the compilers looks for header files?
>  If that's not the case, can you tell me which version of the
>  library you're using? I, of course, test with the newest one,
>  so I would miss something broken in older versions...
>                                  Best regards, Jens

reply via email to

[Prev in Thread] Current Thread [Next in Thread]