[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Custom bibliography commands

From: Arash Esbati
Subject: Re: Custom bibliography commands
Date: Wed, 19 Jan 2022 16:30:11 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/29.0.50

aitor <> writes:

> unfortunately it doesn't seem to work.

I tried this minimal file:

--8<---------------cut here---------------start------------->8---


\newcites{languageresource}{Language Resource}




%%% Local Variables:
%%% mode: latex
%%% TeX-master: t
%%% End:
--8<---------------cut here---------------end--------------->8---

I saved this file under lrec-main.tex and restarted Emacs.  With
`TeX-parse-self' set to t, AUCTeX loads the style multibib.el when I
open the file and is setup for further work, but it still doesn't add
the new macros defined by \newcites to its internal variables.  So I hit
`C-c C-n' to reparse the document and also let RefTeX reparse the file
by choosing it from the menu (Ref->Parse Document->Entire Document).

Now when I hit C-c C-m citelanguageresource RET, I'm asked for an
optional argument where I hit RET and get to RefTeX query for the
regexp where I hit . and see 3 entries to choose from.

With the parsed elements stored in ./auto/lrec-main.el, the steps above
aren't necessary because AUCTeX loads the lrec-main.el and everything
happens automagically.

> This is what I see:
> - `reftex-citation` only searches in the standard bib file
>   (lrec2022-example.bib), but not in the new file
>   (languageresource.bib).
> - When hitting 'C-c C-m' the command \citelanguageresource does indeed
>   appear. The command then asks for items by regex matching, but once
>   again it only looks into "lrec2022-example.bib".

See above.

> - When compiling the document (hitting 'C-c C-c' several times), it does
>   not run bibtex with the "languageresource.aux" file.

Yes, this is still unsolved and I have to think about it.

Best, Arash

reply via email to

[Prev in Thread] Current Thread [Next in Thread]