[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem

From: Charles Millar
Subject: Re: Problem
Date: Sat, 4 Apr 2020 08:19:01 -0400
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Thunderbird/60.9.0

On 4/4/20 3:43 AM, Robert Klein wrote:

Thank you for replying, Robert,

I use ox-koma-letter, and have nothing concerning koma n

- ensure ox-koma-letter is installed
- to install it, add to your local.mk:
   #+begin_src text
     ORG_ADD_CONTRIB = ox-koma-letter

- (require 'ox-koma-letter) in your .emacs

I had already added to my init file (require 'ox-koma-letter) and (add-to-list 'org-latex-packages-alist '("AUTO" "babel" t ("pdflatex"))) as instructed in the Worg tutorial.

- export using C-c C-e k p  (for pdf; l for LaTeX)

Actually I tried all four koma-letter export options and had the same result.

- #+LaTeX_CLASS: scrlttr2

(two t's, not three)

I was alternating between scrlttr2 and default-koma-letter and the last time I put in the extra "t". I have corrected it and still receive the unknon latex class message. As mentioned in my earlier email I confirmed that my org-latex-classes includes ("default-koma-letter" "\\documentclass[11pt]{scrlttr2}")

I also added (add-to-list 'org-latex-packages-alist '("AUTO" "babel" t ("pdflatex"))) to my init file.

Best regards

On Fri, 3 Apr 2020 16:49:15 -0400
Charles Millar <address@hidden> wrote:

I am attempting to use ox-koma-letter, etc.

My set up

GNU Emacs 28.0.50 (build 84, x86_64-pc-linux-gnu, GTK+ Version
3.24.14, cairo version 1.16.0) of 2020-04-03
Org mode version 9.3.6 (release_9.3.6-449-gb99357 @

org-latex-classes includes

"default-koma-letter" "\\documentclass[11pt]{scrlttr2}"

There are no other entries that include scrlttr2 in org-latex-classes

I have a barebones header

#+LATEX_CLASS: scrlttr2 (I also have tried 'default-koma-letter')

and then entered the Romeo to Juliet letter

and i receive the following error

Unknown LaTex class scrlttr2

I searched the list and one suggested problem does not seem to be
applicable - I do not have a mixed org installation.

Any suggestions.

Charlie Millar

reply via email to

[Prev in Thread] Current Thread [Next in Thread]