[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Garbage in files written with tramp

From: Michael Albinus
Subject: Re: Garbage in files written with tramp
Date: Tue, 08 Feb 2005 17:22:16 +0100
User-agent: Gnus/5.1002 (Gnus v5.10.2) Emacs/20.7 (hpux)

Vincent Bernat <address@hidden> writes:


> I have modified mimencode so that it dumps what it reads from stdin in
> a file. I have then diffed the file and the output in debug buffer. It
> seems  that small  chunks are  simply  discarded. The  error seems  to
> happen every 50 lines of base64 data.
> I have read through the  code and seen the variable tramp-chunksize. I
> have tried the code given but my system did not seem to be affected. I
> have  tried with higher  values too,  no change.  However, when  I set
> tramp-chunk-size to 2000, all is working correctly.
> This is a bit odd in regards to the previous tests, but this works.

So it looks like you are suffering from a `process-send-string' of
Emacs (that's why `tramp-chunksize' has been introduced). Strange, it
has never been reported with Debian systems. The only difference wrt
my configuration seems that you're using the multi-tty branch of Emacs.

Do you see a chance to try it with a mainstream Emacs 21.3.50 (aka
22.1.-999, or whatsoever), with `tramp-chunksize' set to nil? In
parallel I'll test with the multi-tty branch of Emacs next days,
hopefully I can reproduce your problem.

(Another test would be with XEmacs 21.4, because the
`process-send-string' problem doesn't seem to appear there. But that
might be too expansive for you.)

Best regards, Michael.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]