[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: tramp (; Copy-paste of folder from Windows machine to Lin

From: Guillaume Demeyère
Subject: Re: tramp (; Copy-paste of folder from Windows machine to Linux server does not work
Date: Wed, 10 Jul 2019 09:56:59 +0200

Hello Michael,

I tried to apply the correction, but I get the same error.

To make sure I understand well the patch I need to apply, I attach to this message the corrected function tramp-find-inline-compress, which I updated with your diff.
Prior to executing the exact same test as last message, I evaluated this function in my emacs -Q (through C-x C-e).

The test gives me the same error. Attached is the new tramp debug file I get.


Michael Albinus <address@hidden> escreveu no dia terça, 9/07/2019 à(s) 15:04:
Guillaume Demeyère <address@hidden> writes:

> Hi Michael,

Hi Guillaume,

> I re-ran the test "copy-file" with emacs -Q beginning with setting
> tramp-verbose to 6. The logs are attached.

Thanks. This is helpful, and I found the problem. Tramp tries to check
whether the local machine does support "gzip":

> 13:26:45.178653 tramp-call-process (6) # `C:/Users/gde3/Documents/emacs-26.2-x86_64/libexec/emacs/26.2/x86_64-w64-mingw32/cmdproxy.exe /c echo xyzzy | "env" "GZIP=" "gzip" | "env" "GZIP=" "gzip" "-d"' nil nil
> 13:26:45.300479 tramp-call-process (6) # 0
> ERROR env: CreateProcessA

The process call returns error code 0 (this is what Tramp checks), but
there is also an error string. Tramp didn't check this. That's why Tramp
has decided it could use "gzip".

It's a pity that on MS Windows one cannot trust the return code. Hmm, so
what. The appended patch shall fix it, could you pls test? Personally, I
don't run MS Windows machines.

> Cordialement,
> Guillaume Demeyère

Best regards, Michael.

Attachment: 2019-07-10-tramp-debug-log
Description: Binary data

Attachment: tramp-correction.el
Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]