[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: tramp hangs

From: Michael Albinus
Subject: Re: tramp hangs
Date: Wed, 18 Sep 2019 15:15:33 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/27.0.50 (gnu/linux)

Mark Geary <address@hidden> writes:

Hi Mark,

> I'm trying to use tramp to edit a file on a Solaris 11 box.

Uhh, Solaris is always problematic.

> This worked until a year (very approximately) ago. I can't think of
> anything that changed at the time it stopped working. I'm fairly
> certain that the upgrade from Solaris 10 to 11 did not coincide with
> the onset of the tramp problems.
> I run "emacs -q" and set tramp-verbose to 6

That's good. But please always send Tramp traces as attachment. Mailers
change line folding, and the traces become almost unreadable.

> When I try to open .profile on sfmg10, I see this in the mini-buffer area:
> Tramp: Opening connection for sfmg10 using ssh...done
> Tramp: Inserting '/ssh:sfmg10:/home/mag43/.profile'...failed
> Emacs then hangs. I interrupt it with C-g.
> The tramp debug buffer follows:

Here we find:

> 17:09:23.769961 tramp-send-command (6) # ( (test -e
> /home/mag43/.profile || test -h /home/mag43/.profile) && (env
> QUOTING_STYLE=locale /usr/ccs/bin/stat -c '((/////%N/////) %h %u %g %X
> %Y %Z %s /////%A///// t %i -1)' /home/mag43/.profile | sed -e
> 's/"/\\"/g' -e 's/\/\/\/\/\//"/g') || echo nil) 2>/dev/null; echo
> tramp_exit_status $?

> 17:09:23.780967 tramp-wait-for-regexp (6) # bash: dev/null: No such
> file or directory
> tramp_exit_status 127
> ///3ccb8c84d92d4fbbce6ab9a5367fc57b#$

What's up with /dev/null on that remote host? Note, that Tramp has
decided to use /usr/ccs/bin/bash there, for whatever reason.

Best regards, Michael.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]