[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: tramp (; Hangs when trying to remote edit files on my ras

From: Michael Albinus
Subject: Re: tramp (; Hangs when trying to remote edit files on my raspberrypi overs sh
Date: Wed, 18 Sep 2019 21:17:17 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/27.0.50 (gnu/linux)

Nicholas Greensmith <address@hidden> writes:

> Hi Michael,

Hi Nicholas,

[Pls keep address@hidden in Cc, for the archives]

> Sorry for the late reply.
> I tried +Z in my shell and it does seem to disable zle.
> I tried changing the parameters you suggested after removing the line
> I mentioned from my .zshrc, but they don't seem to work. Tramp still
> hangs.

Well, what I have added finally in Tramp is "-f +Z". See here:

--8<---------------cut here---------------start------------->8---
tramp-sh-extra-args is a variable defined in ‘tramp-sh.el’.
Its value is
(("/bash\\'" . "-norc -noprofile")
 ("/zsh\\'" . "-f +Z"))
--8<---------------cut here---------------end--------------->8---

> Copy of the debug buffer at the end of the mail.

Hmm, you're right. Tramp hangs with this command:

> 19:57:05.357543 tramp-send-command (6) # exec ssh -l llamacenter -o 
> ControlMaster=auto -o ControlPath='tramp.%C' -o ControlPersist=no -e none 
> raspberrypi.home

It calls your login shell (zsh) indirectly, so there's no chance to
apply the extra args. I will review tha changes I have applied.

> Regards,
> Nicholas

Best regards, Michael.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]