[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Copy-paste of large files from Windows to Linux - base64 issue?

From: Michael Albinus
Subject: Re: Copy-paste of large files from Windows to Linux - base64 issue?
Date: Mon, 20 Jan 2020 12:11:44 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/28.0.50 (gnu/linux)

Guillaume Demeyère <address@hidden> writes:

> Hi Michael,

Hi Guillaume,

sorry for the delay, I wanted to run my own tests. Since I do not use MS
Windows on a regular basis, I had to steal such a machine
temporarily. It runs MS Windows 7 (pls don't discuss with me, it isn't
my own machine). I've installed the recent Emacs 28.0.50 from, which includes Tramp 2.4.4-pre.

It doesn't differ too much from the configuration you use, because all
these process-send-string thingies I haven't touched for years.

> I re-ran the test with Tramp 2.4.3 and tramp-chunksize set to 1. It
> completes with no error. I don't suppose the log (212MB, 18MB when
> compressed) would be helpful with no error, so I'm not adding them to
> this message (but tell me if you need them).
> To make sure this was no coincidence, I re-ran the test several times.
> It worked each time. It also worked with tramp-chunksize set to 2,
> 5,6... It failed with tramp-chunksize set to 10.


> Weirdly enough, I got frequent (but not systematic) fails on
> tramp-chunksize set to 1,2 and 5 but *only when tramp-verbose was left
> unchanged* (to 3).

Sounds like a timing issue.

> All the tests I have been doing until now were made using "emacs -Q".
> The problem only happens with large files (although contrary to what I
> said, the test file 1.bundle.js weighs 2MB, not 20).

Well, I have performed my test also with "emacs -Q", and I haven't set
any additional config. Copying a 2 MiB file (emacsclientw.exe) to a
remote machine works w/o problems.

Hmm, copying emacs.exe to a remote machine (115 MiB) fails, but this is
another file size. Copying with tramp-chunksize set to 10 works,
slowly. I haven't tested with larger tramp-chunksize.

> It is true that I tend to lose my Tramp connection quite often and
> unexplicably. I also get asked for my password from time to time, when
> establishing the connection, even though it should (and does, like,
> 70% of the time) get it right from  ~/.authinfo. During all the tests
> of this morning, it continually asked for the password (could it be
> that the file was locked ?).

Have you tried whether it works with another remote machine? The machine
you have used for your tests reports "Linux 3.10.0-1062.4.1.el7.x86_64",
which is quite old.

> I acknowledge that pscp works perfectly in this use case. However, in
> my real use case, I execute the copy-paste as root (from dired+), and
> to the best of my knowledge, pscp does not support multi-hops (I don't
> know why, but I wish it dit, it would be really useful).

Unfortunately, for technical reasons multi-hops cannot be implemented
for external methods like pscp. I wish it would be possible.

> Best regards,
> Guillaume

Best regards, Michael.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]