avr-gcc-list
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [avr-gcc-list] objdump patch


From: Erik Christiansen
Subject: Re: [avr-gcc-list] objdump patch
Date: Tue, 7 Sep 2004 15:46:03 +1000
User-agent: Mutt/1.3.28i

On Mon, Sep 06, 2004 at 04:39:27PM +0200, Svein E. Seldal wrote:
> The snippet below shows the changes that I suggest. In short:
> 
> 20c:       02 c0           rjmp    .+4             ; 0x212
> 
> becomes
> 
> 20c:       02 c0           rjmp    0x212 <.do_copy_data_start>     ; .+4
> 
> 
> Does this look nice?  Its downside is that it kind of ruins the 
> right-aliged row of ';' and makes the output more cluttered. But on the 
> upside, it proves it faster and simpler to review code.
> 
> What I really want to discuss is if we do need the "; .+4" comment in 
> the example above or not. I dont think I will ever need that 
> information, but I'm humble if anyone else protests.

Svein,

The symbol beneficially replaces the relative reference, both in an
abstract sense and in practical use, doesn't it? I'd very definitely
spend my 2 cents on your clutter reduced alternative, and increase the
separation of the symbol, for readability.

20c:       02 c0           rjmp    0x212     <.do_copy_data_start>

Where no symbol is available, I suppose we end up with

20c:       02 c0           rjmp    0x212     ; .+4

Right alignment is then not bad at all, is it?

Erik



reply via email to

[Prev in Thread] Current Thread [Next in Thread]