discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: OsiriX [Was: environment]


From: Philip G Batchelor
Subject: Re: OsiriX [Was: environment]
Date: Sun, 14 Aug 2011 18:08:29 +0100
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.18) Gecko/20110617 Thunderbird/3.1.11

Yes, you're right. I replaced OSByteOrder.h by NSByteOrder.h:
compilation did indeed go further, although with the message
'Papyrus3/PapyPrivFunctionDef3.h:122:3: warning: implicit declaration of function ‘OSSwapLittleToHostInt64’
[...]
gcc: apps: linker input file unused because linking not done'
which suggests potential trouble.

But in any case, another attempt at 'make' went further but brought another problem: it tries to find
'Accelerate.h' which is OSX specific, and contains stuff about hardware acceleration (seems to be vectorisation and BLAS etc related). I tried to avoid the problem by commenting some stuff out, but this causes error as  the type 'vFloat' is undefined, so I guess if there is a workaround, it will require defining a type 'vFloat' in a linux specific way. Along the lines of http://lists.apple.com/archives/perfoptimization-dev/2009/Mar/msg00006.html
I'll try having a  closer look when I have time--I need to read about VFP.

(I guess these are the library issues mentioned by Fred Kiefer?)

Thanks again for the suggestions

Ph



On 14/08/11 13:52, Ivan Vučica wrote:
Copypasting a header from a wrong OS can only mean problems. I recommend you don't do that.

Best route would be trying to use just libraries natively available on your target platform (such as Linux). In any case, it would be best if you convinced upstream authors to maintain a GNUstep build officially, either by contributing patches they would accept or by convincing them GNUstep is a good target.

On Sun, Aug 14, 2011 at 13:19, Philip G Batchelor <address@hidden> wrote:
Thanks for the suggestions,

inbetween I had googled a bit, and I was considering two options:

Option 1: somebody tried and had that problem
http://old.nabble.com/Compiling-Osirix-with-GnuStep-td25938560.html
so maybe try the suggested solution (although apparently it led to further problems down the line--and it's a while ago).

Option 2: I found libkern/OSByteOrder.h online, as part of Chameleon which seems to be abooloader?
I check it out, in case of.

So I'll add the two suggested Options to that of:

Option 3: trying to replace with NSByteOrder

Option 4: asking OsiriX developers, and indeed the problem is now more of an OsiriX one.

I guess I'll try them all, maybe starting with 2 (although typing 'make' just nearly froze my PC...) as it shouldn't require changing the actual code. (But NSByteOrder sounds better in long term).

Ph



On 14/08/11 11:44, David Chisnall wrote:
On 14 Aug 2011, at 11:05, Philip G Batchelor wrote:

(For the moment, Osirix compilation fails at  'libkern/OSByteOrder.h: No such file or directory' but that was a first attempt,
I'll try more).
The OSByteOrder stuff is more or less the same as the NSByteOrder stuff, so it should be relatively simple to rewrite it to use NSByteOrder.  No idea why they'd use the libkern interfaces - they're only meant to be used for low-level things that can't link against Foundation.

David

-- Sent from my Difference Engine





_______________________________________________
Discuss-gnustep mailing list
address@hidden
https://lists.gnu.org/mailman/listinfo/discuss-gnustep



--
Ivan Vučica - address@hidden




reply via email to

[Prev in Thread] Current Thread [Next in Thread]