discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

AClock [Re: GNUstep Objective-C v2 ABI update]


From: David Chisnall
Subject: AClock [Re: GNUstep Objective-C v2 ABI update]
Date: Tue, 1 Jan 2019 19:26:22 +0000
User-agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:60.0) Gecko/20100101 Thunderbird/60.3.3

On 01/01/2019 13:20, Fred Kiefer wrote:
Am 01.01.2019 um 13:31 schrieb David Chisnall<address@hidden>:

On 01/01/2019 01:00, Patryk Laurent wrote:
Hi David,
A couple days ago I installed FreeBSD 12.0 and after pkg ins Aclock and openapp 
AClock I got a crash. Are you saying that would now be fixed?  Do I just 
uninstall gnustep and reinstall to get the fix?
Sadly no.  AClock is crashing in -gui while deserialising the nib.  I guess 
something in the nib format is unsupported by recent versions of -gui?

I have not yet pushed the changes to the ports, and it will be a day or two 
after I do that before packages appear.
Which version of Clock are you two referring to? I just compiled the one from 
GAP and it works fine on my machine, but this also does not contain any NIB 
file.

It appears that the 0.4 release was from October 2011. Riccardo has made a bunch of improvements to the codebase since then and the latest version from GitHub builds and appears to work fine. Perhaps we could have a new release?

David



reply via email to

[Prev in Thread] Current Thread [Next in Thread]