[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Lilypond code/feature freeze for 2.12

From: Trevor Daniels
Subject: Re: Lilypond code/feature freeze for 2.12
Date: Mon, 22 Sep 2008 10:45:56 +0100

John Mandereau Monday, September 22, 2008 12:02 AM

On 2008/09/20 18:49 -0700, Graham Percival wrote:
Forgot something: we should probably add warnings in the docs (or the
download page) about the sorry state of OSX.

10.4 and 10.3: broken lilypond-book and convert-ly.  The broken
convert-ly is particularly unfortunate given the syntax changes between
2.10 and 2.12.

These Python scripts require Python 2.4, which is not provided in 10.3
and 10.4; ideally we should cross-compile Python and ship it in GUB
binaries, but it could be a nightmare to make it possible (I cannot even
compile current GUB right now, so I'm far from being able to do this
within one or 2 weeks).

The only solution on short term is asking users to install Python 2.4 or
2.5 manually; IIRC Python scripts and/or their wrappers also need to be
edited to make them call the right Python, don't they?

Do we -really- want to issue a new stable release
containing masses of syntax changes with a broken
convert-ly for many Mac users?

I think that would be a mistake.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]