bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#9684: Emacs 23.3 and 24.0.90 don't build on IRIX 6.5


From: Rainer Orth
Subject: bug#9684: Emacs 23.3 and 24.0.90 don't build on IRIX 6.5
Date: Fri, 07 Oct 2011 11:11:46 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.3 (usg-unix-v)

Eli Zaretskii <address@hidden> writes:

> Does it help to drop the -j8 switch to Make?

Unfortunately not: just running make yields

Loading tooltip...
Finding pointers to doc strings...
Finding pointers to doc strings...done
Dumping under the name emacs
1465234 pure bytes used
Adding name emacs-24.0.90.1
emacs: Invalid function: make-local-variable
make[1]: Leaving directory `/vol/obj/gnu/emacs/emacs-24.0.90/src'
cd lisp; make all                            \
          CC='gcc -std=gnu99' CFLAGS='-g -O2' CPPFLAGS='' \
          LDFLAGS='-Wl,-znocombreloc ' MAKE='make'
make[1]: Entering directory `/vol/obj/gnu/emacs/emacs-24.0.90/lisp'
make[2]: Entering directory `/vol/obj/gnu/emacs/emacs-24.0.90/lisp'
make[2]: Nothing to be done for `compile-targets'.
make[2]: Leaving directory `/vol/obj/gnu/emacs/emacs-24.0.90/lisp'
make[1]: Leaving directory `/vol/obj/gnu/emacs/emacs-24.0.90/lisp'
(export PARALLEL; PARALLEL=0; cd leim; make all  \
          CC='gcc -std=gnu99' CFLAGS='-g -O2' CPPFLAGS='' \
          LDFLAGS='-Wl,-znocombreloc ' MAKE='make')
make[1]: Entering directory `/vol/obj/gnu/emacs/emacs-24.0.90/leim'
mkdir quail
touch stamp-subdir
EMACSLOADPATH=/vol/src/gnu/emacs/emacs-24.0.90/leim/../lisp LC_ALL=C 
../src/emacs -batch --no-site-file --no-site-lisp -l 
/vol/src/gnu/emacs/emacs-24.0.90/leim/../lisp/international/titdic-cnv \
          -f batch-titdic-convert -dir quail 
/vol/src/gnu/emacs/emacs-24.0.90/leim/CXTERM-DIC; \
          echo "changed" > changed.tit
emacs: Invalid function: make-local-variable
Compiling quail/CCDOSPY.el
emacs: Invalid function: make-local-variable
make[1]: *** [quail/CCDOSPY.elc] Error 1
make[1]: Leaving directory `/vol/obj/gnu/emacs/emacs-24.0.90/leim'
make: *** [leim] Error 2

> And what version of GNU Make is that, btw?

address@hidden 150 > make --version
GNU Make 3.81

The same one that worked for 23.2 and all my GCC bootstraps.

        Rainer

-- 
-----------------------------------------------------------------------------
Rainer Orth, Center for Biotechnology, Bielefeld University





reply via email to

[Prev in Thread] Current Thread [Next in Thread]