bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#9684: Emacs 23.3 and 24.0.90 don't build on IRIX 6.5


From: Rainer Orth
Subject: bug#9684: Emacs 23.3 and 24.0.90 don't build on IRIX 6.5
Date: Tue, 11 Oct 2011 16:21:38 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.3 (usg-unix-v)

Dan,

> I don't think there have been too many important changes in the dumping
> infrastructure, so if something broke is probably an oversight.
>
> You can try compiling a version of emacs that is known to work.
> Compile the bzr trunk with the same compiler + flags (maybe use just -O0).
> Compare the two "emacs" binaries, use readelf to compare the elf
> sections, maybe there's something obvious. 
> Compare the two versions of unexelf.o, and maybe the corresponding
> preprocessed files (there shouldn't be many interesting differences).
> Try linking the trunk temacs with the old unexelf.o and see if you
> get better behavior.

as an intermediate datapoint: while looking for a version of emacs that
built correctly, I found that even 23.2 didn't when using gcc 4.4 or
3.4.  Fortunately, I had a 9 years old copy of gcc 3.1 around, which was
able to build both a working emacs 23.2 and 24.0.90 (from the tarball).

I'll start digging deeper from here, but it may take a bit.

        Rainer

-- 
-----------------------------------------------------------------------------
Rainer Orth, Center for Biotechnology, Bielefeld University





reply via email to

[Prev in Thread] Current Thread [Next in Thread]