[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] UHD won't work with GRC

From: Alexandru Csete
Subject: Re: [Discuss-gnuradio] UHD won't work with GRC
Date: Fri, 21 Jan 2011 14:54:23 +0100

Hi Fabian,

Did you set the PYTHONPATH?
It should be set to PREFIX/lib/python2.6/site-packages where PREFIX is
whatever you have specified during "./configure --prefix=..."
(/usr/local if you haven't specified anything). Check the directory,
there should be a subdirectory called gnuradio and one called

A few other notes:

It seems you have two UHD installations:
>> ./usr/local/lib/libuhd.so
>> ./opt/uhd/lib/libuhd.so
You should uninstall one of them (btw. is there really a '.' in the
path's above?)

You should not specify multiple locations for the installed libraries,
i.e. if you install UHD in /opt/uhd you should add /opt/uhd/lib to the
LD_LIBRARY_PATH but not the source location. The same for GNU Radio

It looks like you have installed boost 1.37 from source. While that's
okay, it is only required for Ubuntu 8.04 or older and you may get
into trouble if you have also installed a binary package from Ubuntu

It seems many newcomers become confused with the Ubuntu installation
instructions. I think it is because it covers many versions going all
the way back to 6.10 so a lot of information is irrelevant for those
who use a recent version of Ubuntu. I'll try to find some time to fix
that by splitting the page in two.


On Fri, Jan 21, 2011 at 2:02 PM, Fabian Klaes <address@hidden> wrote:
> I first tried make distclean and the installation went fine, but when I
> tried to start the GRC, following window showed up:
> http://tinypic.com/r/dq671d/7 containing the error message "Cannot import
> gnuradio. Are your PHYTONPATH and LD_LIBRARY_PATH set correctly?"
>> I then tried git clean -dfx and rebuilding from scratch (for UHD and
>> GNUradio).
>> Installation for UHD (worked):
>> git clone git://code.ettus.com/ettus/uhd.git
>> cd uhd/host
>> mkdir build
>> cmake -DCMAKE_INSTALL_PREFIX=/opt/uhd ../
>> make
>> make test
>> sudo make install
>> PATH=$PATH:/opt/uhd/bin
>> uhd_find_devices and uhd_usrp_probe works fine now, so i figured that the
>> installation of UHD was successfull
>> Installation for GNUradio (error at ./configure):
>> git clone git://gnuradio.org/gnuradio.git
>> git branch --track next origin/next
>> git checkout next
>> export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:${PKG_CONFIG_PATH} #just
>> to be sure ...
>> BOOST_PREFIX=/opt/boost_1_37_0 #echo $BOOST_PREFIX returned nothing in the
>> first place, so i figured it could help
>> LD_LIBRARY_PATH=/home/fs/gnuradio-git/uhd/host/build/lib/:/opt/uhd/lib/:/opt/boost_1_37_0/lib
>> #I also put both uhd paths in ld.so.conf and ran sudo ldconfig, but it
>> didn't help
>> ./bootstrap
>> ./configure --with-boost=$BOOST_PREFIX  --enable-gr-uhd
>> Now following error showed up:
>> checking for UHD... no
>> gr-uhd requires libuhd 2.x.x
>> configure: error: Component gr-uhd has errors; stopping.
>> I did: find |grep libuhd and got:
>> ./home/fs/gnuradio-git/uhd/host/build/lib/libuhd.so
>> ./home/fs/gnuradio-git/uhd/host/build/lib/libuhd.so.002
>> ./usr/local/lib/libuhd.so
>> ./opt/uhd/lib/libuhd.so
>> ./opt/uhd/lib/libuhd.so.002
>> so I added /opt/uhd/lib/ and /home/fs/gnuradio-git/uhd/host/build/lib/ to
>> ld.so.conf and ran sudo ldconfig (as said above). I then also tried to set
>> LD_LIBRARY_PATH (see above again) but still the same error.
>> I also tried to git clone from http://gnuradio.org/git/gnuradio.git
>> (described in [1]) instead of git://gnuradio.org/gnuradio.git (described in
>> [2])
>> I don't know what to do next and would appreciate any help (again). I
>> would be really happy if we could get this going.
>> Fabian
>> [1] http://gnuradio.org/redmine/wiki/1/UbuntuInstall
>> [2] http://ettus-apps.sourcerepo.com/redmine/ettus/projects/uhd/wiki
>> On Thu, Jan 20, 2011 at 5:13 PM, Josh Blum <address@hidden> wrote:
>>> > And the (probably) critical part causing the error:
>>> > make[6]: *** Keine Regel vorhanden, um das Target »usrp_prims.cc«,
>>> >   benötigt von »_usrp_prims_la-usrp_prims.lo«, zu erstellen.  Schluss.
>>> > make[6]: *** No Rule given, for making Target »usrp_prims.cc«,
>>> >   needed by »_usrp_prims_la-usrp_prims.lo«.  Ending.
>>> >
>>> >
>>> > If you (or anyone else) got another hint on how to solve this i would
>>> > be
>>> > really glad.
>>> >
>>> Sometimes autotools gets confused when there are many changes to the
>>> build system. Try make distclean, and if not working: git clean -dfx
>>> (wipes everything). and rebuild from scratch.
>>> -Josh
>>> _______________________________________________
>>> Discuss-gnuradio mailing list
>>> address@hidden
>>> http://lists.gnu.org/mailman/listinfo/discuss-gnuradio
> _______________________________________________
> Discuss-gnuradio mailing list
> address@hidden
> http://lists.gnu.org/mailman/listinfo/discuss-gnuradio

reply via email to

[Prev in Thread] Current Thread [Next in Thread]