[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] GR 3.5.1 & OSX

From: Arturo Rinaldi
Subject: Re: [Discuss-gnuradio] GR 3.5.1 & OSX
Date: Sat, 24 Mar 2012 00:25:12 +0100
User-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:11.0) Gecko/20120313 Thunderbird/11.0

Nella citazione in data Thu Mar 22 23:43:29 2012, Arturo Rinaldi ha scritto:
Nella citazione in data Thu Mar 22 15:17:03 2012, Michael Dickens ha
On Mar 22, 2012, at 9:55 AM, Arturo Rinaldi wrote:
I think i've sorted out the dependencies for building gnuradio on
Lion 10.7.3

sudo port install boost icu cppunit fftw-3-single gawk \
readline gsl texinfo guile python27 py27-numpy py27-nose
py27-distribute \
libsndfile portaudio py27-opengl py27-opengl-accelerate py27-pil
lcms py27-tkinter \
py27-wxpython wxWidgets mesa makedepend xorg-dri2proto xorg-glproto
xorg-libXmu \
py27-cheetah py27-gtk libglade2 py27-cairo py27-py py27-gobject
py27-lxml doxygen \
libusb-legacy sdcc29 gputils py27-pyqt4 py27-sip py27-pyqwt qt4-mac
dbus libmng qt4-mac qwtplot3d qwt52 libsdl

Yeah; I'd believe that. Nothing like a "few" background dependencies
as added by MacPorts to those top-level ones. I tried creating a
stand-alone .app for GRC, and it turned out to be something like 600
MB when all of these dependencies were included. Many of them are
spurious -- not directly relevant -- but include as options or
whatever. MP folks have had a discussion about this issue recently,
since it's a real problem.

However :

py27-wxpython doesn't install on macports. I'll post it on the
macports mailing list then we aren't able to use the wxgui module

There's are a few discussions about py27-wxpython on various MP lists
right now. Seems like maybe you're not alone. Please do search for a
ticket for:< https://trac.macports.org/search>. I have no issue with
this port on 10.6.8, and it works correctly with 64-bit Wx!

by using autotools with

./configure LDFLAGS="-L/opt/local/lib"
CPPFLAGS="-I/opt/local/include" CC=clang --disable-gr-qtgui

builds the latest tarball ( and i need some help for the
DYLD_LIBRARY_PATH because gnuradio-companion start with an error
message though PYTHONPATH is correctly set

You should be able to compile GR without LDFLAGS or CPPFLAGS, if
you've set the PKG_CONFIG_PATH to include "/opt/local/lib/pkgconfig".
You'll probably want to set CXX to clang++ (or, whatever that is
called) along with CC; I don't think CC is actually used, but it
can't hurt to set it. Once installed, you should be able to execute
GR scripts and GRC without resorting to the DYLD_LIBRARY_PATH -- the
PATH and PYTHONPATH should be sufficient.

downloaded the git version and after the usual steps with cmake, the
building crashes at the 3% with the error

cc1: error: unrecognized command line option "-mpopcnt"
make[2]: ***
[volk/lib/CMakeFiles/volk.dir/volk_machine_sse4_a_64.c.o] Error 1
make[1]: *** [volk/lib/CMakeFiles/volk.dir/all] Error 2
make: *** [all] Error 2

No idea, but using CMake is the way to go to get Volk working. Could
be an OSX 10.7 issue; I'm still using 10.6 though I do do testing
using an OSX 10.7 boot disk. I haven't tried this in a while, so I'll
give it a whirl later today or tomorrow, as time allows.

Good luck! - MLD

Discuss-gnuradio mailing list

ok i'll do other "experiments" and report news.....thx very much :D

downloaded the latest git version and made a little progress in the third case. I set :

export CXX=clang++
export CC=clang

and the cmake building worked ! ! !. Now i have to set the python path correctly. GRC still doesn't run but the python interpreter import the gnuradio module correctly.

i removed the documentantion from building because it seems to stuck at a certain point, and cpu(s) load is at full ! ! !

The py27-wxpython issue still remains, i'll post a ticket on macports

Regards, Arturo

reply via email to

[Prev in Thread] Current Thread [Next in Thread]