discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: new gui bug (focus? gorm?)


From: Riccardo Mottola
Subject: Re: new gui bug (focus? gorm?)
Date: Mon, 24 Nov 2003 12:16:04 +0100
User-agent: Microsoft-Outlook-Express-Macintosh-Edition/5.02.2022

on 11/24/03 3:10 AM, Gregory John Casamento at address@hidden
wrote:

> I have tried this on my box and I don't see the same issue, please see
> attached
> .png for proof.

I believe you. But here it is broken. To be scrupuolous I tested it on the
other PowerMac I have that runs MkLinux. On that computer, which I use
mostly as a testbed for new MkLinux packages and similar, I have gnustep
"release" built from the tarballs adam publishes and not from CVS. I also
built Gorm "release" that is found on the gnustep site: 0.3.1

I repeat the procedure and woah... the spings come!
But the joy was to come to an abrupt end: I stimulated clicking the springs
a bit and at one point everything freezes as usual. NO click, focus,
nothing. I kill from another console gorm but X11/wmaker remain confused,
mouse clicking doesn't work correctly and the keyboard typing does random
stuff! Restarting X11 solved that.

I repeat the scenario a second time. What it seems that clicking several
times on the springs inside the window works, as soon as aI click two times
or so on an external one: freeze.

On the "CVS" version of everything I get a freeze at the first attempt to
click (the spring doesn't even change state).

The two computers have the same os, dev tools and such isntalled (from the
same cd).

If I leave gorm running with everything freezed, the application continues
to increase its memory consumption.

This is a similar behavior that I found with the infamous button alignment
but, if you rememer. ANd I think it was never solved :-(
There must be something that runs in an allocation loop or so?

bye
    Ric





reply via email to

[Prev in Thread] Current Thread [Next in Thread]