[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Compiling gnustep-make

From: Yavor Doganov
Subject: Re: Compiling gnustep-make
Date: Sun, 4 Feb 2018 01:09:24 +0000 (UTC)
User-agent: Pan/0.144 (Time is the enemy; 28ab3ba git.gnome.org/pan2)

В Thu, 01 Feb 2018 09:39:33 +1100, Svetlana Tkachenko написа:
> Ivan Vučica wrote:
>> Have you uninstalled a previous installation of GS fully?
> I now did 'apt purge *gnustep*' and that showed that some packages
> still needed removal. However I then rebooted and tried to compile
> GNUstep Make again and it produced the same error message.

Then you definitely have some remnants from an old installation.  It
could be from a debian package (purge removes every file *dpkg* knows
about), something in /usr/local or $HOME.

I had to install GNUstep on ~20 machines recently, it worked
flawlessly with 2.7.0.  If you'are trying with the master branch it
shouldn't make any difference; there are a few unrelated commits on
top of 2.7.0.

> Yavor Doganov wrote:
>> Or you can install in the USER domain which always takes
>> precedence.
> How do I install in the USER domain?


Or, if you don't have root access and/or intend to install in the USER
domain most of the time, you can put in your ~/.profile:


and then use just `make install' which would install in the USER
domain.  You can still explicitly specify `make install
GNUSTEP_INSTALLATION_DOMAIN=LOCAL' in cases when you need to.

>> That's what I'm doing and it works nicely except when testing changes
>> to GNUstep Make.
> Why don't you install GNUstep Make into the USER domain as well?

Well, GNUstep Make introduces the concept of domains, you cannot
install it in the USER or any other domain without extra hoops, it
honours --prefix.

> Now gnustep-base says objc headers are missing, what package is that
> in Debian? I already tried objc*dev but the error remains.

What are you trying to do?  You must have an Objective-C compiler and
runtime before configuring GNUstep Make.  You build the compiler and
the runtime first, then Make, Base, Gui, Back and the rest of the
GNUstep world.  GNUstep Base has a configure check to detect if
there's a mismatch between its own and gnustep-make's configuration.

If you have gobjc/gobjc-7 installed, you already have the GNU
Objective-C runtime headers (libobjc-7-dev).  If you intend to use
Clang and the GNUstep runtime, you have to remove gobjc, install clang
as a debian package (or build it manually if you wish) and
build/install the GNUstep runtime before configuring GNUstep make.

There is no Debian package for the GNUstep runtime (aka libobjc2).

reply via email to

[Prev in Thread] Current Thread [Next in Thread]