[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Compiling gnustep-make

From: Svetlana Tkachenko
Subject: Re: Compiling gnustep-make
Date: Mon, 05 Feb 2018 06:24:14 +1100

Hello All,

Yavor Doganov wrote:
> > Now gnustep-base says objc headers are missing, what package is that
> > in Debian? I already tried objc*dev but the error remains.
> What are you trying to do?  You must have an Objective-C compiler and
> runtime before configuring GNUstep Make.  You build the compiler and
> the runtime first, then Make, Base, Gui, Back and the rest of the
> GNUstep world.  GNUstep Base has a configure check to detect if
> there's a mismatch between its own and gnustep-make's configuration.
> If you have gobjc/gobjc-7 installed, you already have the GNU
> Objective-C runtime headers (libobjc-7-dev).  If you intend to use
> Clang and the GNUstep runtime, you have to remove gobjc, install clang
> as a debian package (or build it manually if you wish) and
> build/install the GNUstep runtime before configuring GNUstep make.
> There is no Debian package for the GNUstep runtime (aka libobjc2).

I compiled GNUstep Make.
Then I tried to compile GNUstep Base.
It says this: http://dpaste.com/0AEA0ZE.txt

Ivan Vučica wrote:
> You didn’t say anything about how the env vars were in your environment after 
> a reboot?
> Did you check if they are there using the “env” command? Did you find out 
> what left them there and cleaned that thing away?

'env|grep GNUSTEP' says...
address@hidden:~$ env|grep GNUSTEP # I do not know what makes this
address@hidden:~$ source /usr/local/share/GNUstep/Makefiles/GNUstep.sh # this 
was made by GNUstep Make that I compiled
address@hidden:~$ env|grep GNUSTEP

-- Sveta

reply via email to

[Prev in Thread] Current Thread [Next in Thread]