[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

DJGPP only dumps with USE_LISP_UNION_TYPE ??

From: Jan D.
Subject: DJGPP only dumps with USE_LISP_UNION_TYPE ??
Date: Sun, 7 Nov 2004 11:13:18 +0100


I was trying to get Emacs to compile on djgpp 2.03. But it crashed every time in the dump phase, at the first GC. I tried different gcc versions (2.95, 3.22, 3.42), different binutils versions (2.11, 2.15), with and without optimizations, with and without debugging but it always crashed at the same spot. Since it crashed in GC, I tried to set the USE_LISP_UNION_TYPE (found a couple of errors and checked them in), and to my surprise, I got a working Emacs.

Does this sound familiar to anyone? Shouldn't with and without USE_LISP_UNION_TYPE be the same at runtime? I was wondering if this could happen at other systems besides djgpp, and if there is some subtle Lisp_Object handling bug somewhere. I've attached some debugging output. If anyone has any idea and want more debugging done, I can provide it.


        Jan D.

Attachment: symify.out
Description: Binary data

Attachment: debug.out
Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]