[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Another VC terminology change?

From: Eli Zaretskii
Subject: Re: Another VC terminology change?
Date: Fri, 12 Oct 2007 10:14:52 +0200

> Date: Thu, 11 Oct 2007 10:30:05 -0400
> From: "Eric S. Raymond" <address@hidden>
>     The terms ``checkin'' and ``checkout'' are associated with file-based
>     and locking-based systems and a bit archaic; nowadays those operations
>     are usually called ``commit'' and ``update''.
> Since I've had to take a big hammer to VC's terminology anyway to clean up the
> inconsistencies Stefan pointed out, I'm thinking now might be a good time
> for me to go further and change these.
> The argument against, of course, is that users are accustomed to these
> terms.  They're embedded in VC because when I originally wrote it SCCS
> and RCS were the only games in town[1] and these are the terms they used.
> The argument for is that 'commit' and 'update' are a better match for the
> terms CVS introduced and every subsequent VCS we're interested in has pretty
> much retained.

How about making the replacement, but adding a footnote saying that
some older VCS backends call these operations ``checkin'' and

reply via email to

[Prev in Thread] Current Thread [Next in Thread]