[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Rename `mini-' options

From: Deniz Dogan
Subject: Re: Rename `mini-' options
Date: Sat, 16 May 2009 02:12:29 +0200

2009/5/15 Drew Adams <address@hidden>:
> Names such as `resize-mini-windows' and `max-mini-window-height' are
> unfortunate. They prevent you from easily finding them by looking for names 
> that
> include `minibuffer' or even `minibuf'.
> Since when did `mini' start being used in option etc. names to stand for the
> minibuffer? The only variable names with `mini-' are these two plus
> `kmacro-step-edit-mini-window-height'. Obviously, given the last of these, the
> name length is not of supreme importance. And there are *no* functions with
> `mini-' in their names.
> It would have been sufficient, if the name length were so important, to use
> `minibuffer-resize' or `minibuf-auto-resize'. Similarly,
> `minibuffer-max-height'. And `minibuffer' should probably come first in the
> name: `minibuffer-resize', not `resize-minibuffer'.
> We should change the names of the `mini-' window options and use temporary
> aliases to ease deprecation of those names.

Unless I had read your post I never would have guessed
`resize-mini-windows' deals with the minibuffer at all.

resize-mini-windows is a variable defined in `C source code'.
Its value is grow-only

*How to resize mini-windows.
A value of nil means don't automatically resize mini-windows.
A value of t means resize them to fit the text displayed in them.
A value of `grow-only', the default, means let mini-windows grow
only, until their display becomes empty, at which point the windows
go back to their normal size.

This is the first time I encounter something called "mini-windows",
but it seems to me, after having read the documentation for the
variable, that the minibuffer is an instance of them? Are there any
other mini-windows or is this just very poorly documented?

Deniz Dogan

reply via email to

[Prev in Thread] Current Thread [Next in Thread]