[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnash-dev] After upgrading to Firefox 24, YouTube videos never load

From: scott092707
Subject: Re: [Gnash-dev] After upgrading to Firefox 24, YouTube videos never load
Date: Tue, 19 Nov 2013 20:37:58 -0500 (EST)

--->Sandro Santilli address@hidden
Thank you for your input!

You need to run gnash from the commandline with
>-v switch (up to 3 of them :)
You asked for it, you have it!

The enclosed 4 files are 4 different invocations of the gnash player with the same YouTube video.

I first made sure that the video played OK in the browser (with the Media-Handler as gst in the config. file).

Then I ran the same video in the gnash player from the terminal, verifying that it ran OK with
the Media-Handler as gst.  It did.  This is the first text file.

Then I ran it 3 more times with
the Media-Handler as ffmpeg,
with -v, -v -v, and  -v -v -v.  All failed to play (as expected).
These are the other 3 files.

One thing I notice that was in the ffmpeg output that was not in the gst output was the following 4 lines, the 3rd
of which was printed in gold-colored text in the terminal, which normally is the usual white on black (yes, I know - very un-original...)
"4094:1] 21458 UNIMPLEMENTED: MediaParserFfmpeg: unsupported whence value 65536
4094:1] 21458 UNIMPLEMENTED: MediaParserFfmpeg seek from end of file
[mov,mp4,m4a,3gp,3g2,mj2 @ 0xb1287000] overread end of atom 'stss' by 160 bytes
4094:4] 21459 ERROR: MediaParserFfmpeg::parseNextFrame: Problems parsing next frame (av_read_frame returned -541478725). We'll consider the stream fully parsed."
[The 8-digit hex number in the gold line ("
0xb1287000" in this case) was actually different for each invocation, I now notice...
The weird negative number "
-541478725" in the 4th line was identical each time.]

The corresponding output from the gst (which for both gst and ffmpeg
immediately followed the line:
"3994:1] 23092 SECURITY: Load from host granted (default)") was:
"3994:1] 24474 UNIMPLEMENTED: MediaParserGst won't set codec, sampleRate, sampleSize, stereo and duration in AudioInfo"

I can't be sure, but I THINK that these lines are the first divergence in output between gst and ffmpeg (for the same level of -v, anyway).

Let me know of anything more I can do to help.


Attachment: gnash_gst_v.txt
Description: Text document

Attachment: gnash_ffmpeg_v.txt
Description: Text document

Attachment: gnash_ffmpeg_v_v.txt
Description: Text document

Attachment: gnash_ffmpeg_v_v_v.txt
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]