[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnumed-devel] Ubuntu-specific issues

From: Karsten Hilbert
Subject: Re: [Gnumed-devel] Ubuntu-specific issues
Date: Mon, 26 Oct 2009 14:11:22 +0100
User-agent: Mutt/1.5.20 (2009-06-14)

On Sun, Oct 25, 2009 at 07:28:26AM +0200, Jerzy Luszawski wrote:

> I know that the reference platform for Gnumed is Debian,
> but I use it under Ubuntu, and sometimes I run into
> Ubuntu-specific problems. 

> This time I tried to bootstrap the latest database, and was stopped by the 
> first check made by gm-bootstrap_server script.
> The line below does not work in Ubuntu:
> ===========
> if ! su -c "psql -t -d template1 -c \"show lc_ctype;\"" postgres | grep -q -e 
> C -e UTF-8 ; then
> ===========
> Ubuntu has a little different security defaults and "su
> -c" is not used (no user has a permission to do "su").
> Instead, permission to  use "sudo" is granted.

I agree this should be filed against the Ubuntu package as a
Request For Improvement.

I am fine with sudo myself but it would require sudo to be

Either way this is just GNUmed providing high-level
syntactic sugar for what's really a distribution specific
task and can thus never please all distributions.

OTOH, we can hopefully "soon" remove *this* particular line
entirely because PostgreSQL 8.4 does not require that
precaution anymore AFAICT. Maybe in 6 months or so.

> This is no problem to me, but may confuse other users trying/evaluating 
> Gnumed.

Good catch.

> Maybe it is worth mentioning in Wiki? I and others could
> then report another Ubuntu-specific issues, which are
> important when building the package for this distro.

Exactly ! Thanks for reporting this issue !

GPG key ID E4071346 @
E167 67FD A291 2BEA 73BD  4537 78B9 A9F9 E407 1346

reply via email to

[Prev in Thread] Current Thread [Next in Thread]