[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnump3d-users] APE files in gnump3d

From: Steve Kemp
Subject: Re: [Gnump3d-users] APE files in gnump3d
Date: Mon, 30 Jan 2006 10:05:47 +0000
User-agent: Mutt/1.5.9i

On Mon, Jan 30, 2006 at 08:39:42AM +0100, David Bosque wrote:

> I have /etc/gnump3d/mime.types symlinked to /etc/mime.types, is there 
> any problem with that? I ask because my system's mime.type is about 1KB 
> bigger tant gnump3d's.

  No, there is no problem with that.

  (The only reason I included the file in the distribution was to solve
 the problem where some distributions had very old mime.type files,
 looks like mine is now out of date!)

> > Add the following line there, and restart the server:
> >
> >$AUDIO_SUFFIXES{ "ape" } = 1;
> > 
> >
> That did it. Thanks :-).


  For people following at home, using the CVS version, there is
 a new configuration file /etc/gnump3d/file.types which is used to
 specify which suffixes are audio/playlists/movies.

  That will be included in the next release.

> It's working almost perfectly, and I say almost because it is working in 
> VLC under windows and xmms under linux, but not under winamp...?? Winamp 
> does play gnump3d's mp3 streams even when they are downsampled so why 
> wouldn't it play these? I've tried using
> audio/mpeg                                   mpga mpega mp2 mp3 m4a ape
> in /etc/mime.types instead of an audio/x-ape mime.type but still no 
> go...Any ideas on this?

  Perhaps the mime-type which is being served is the "old" ape one,
 instead of the converted one which should be sent - since you're now
 serving .mp3 files instead of the ape ones.

  If you could do a "wget", or something similar to see if you're
 getting the correct mime.type file served that might help.

  If that is the problem adjusting the mime.type file to have
 audio/mp3/whatever for .ape files would do the job I'd guess.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]