[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Groff] CVS Build Problem

From: Keith MARSHALL
Subject: Re: [Groff] CVS Build Problem
Date: Mon, 25 Apr 2005 11:45:05 +0100

Larry Jones wrote:
> Keith Marshall writes [quoting me]:
>>> There is a DESC file in /pubic/GNU/groff/font/devps, so I'm not sure 
>>> it's not being found.
>> Presumably you have checked to ensure that it has sensible access 
>> assigned?  Inspected it, to ensure its content is appropriate?
> Yes, it's built earlier in the process and seems to be fine.
>> You don't say what platform you are building on.
> BSD/OS 4.2.

Ahhh.  IIRC, Jim Reid had a similar problem a few months ago, also on BSD.
Don't know what version he was using, or if he ever found a solution :-(

>> What shell is being used? 
> bash.

That should be good, then :-)

>> What configure options did you specify?
> None.

So, no clues there either, then :-(

>> I guess, since it announces itself 
>> as `gmake', that you _are_ using GNU make.
> I've tried both the standard (BSD) make and gmake -- no difference.
>> Sorry, but I can't see any obvious clues in the make trace you posted.
> Neither can I, that's why I'm asking for help.  :-)
> It doesn't look like a make problem to me, it looks like something's not
> working right in the font file search logic, ...

I am inclined to agree; but it seems to be something peculiar to the way
this logic behaves on BSD, since it seems to work fine on other platforms.

> ... but I don't know enough
> about it to even know where to start trying to debug it.  The last
> version of groff I built on this platform was 1.15, so it's been a
> while, but it worked fine.

Wish I could be more helpful, but without a BSD system, I'm not sure what 
can do :-(  Like you, I'm not even sure either, where to look for the code
in which the fault might lie.  If I can find the time later, I'll have a
look around.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]