[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Groff] Still No Luck Accessing Characters From Zapf Dingbats (Or An

From: Werner LEMBERG
Subject: Re: [Groff] Still No Luck Accessing Characters From Zapf Dingbats (Or Any Other Strange Font)
Date: Mon, 09 May 2016 07:02:03 +0200 (CEST)

> So I am on El Capitan, and I am using the groff which comes
> installed with El Capitan, GNU groff version 1.19.2

Uh, oh, this version was released in 2005!  Current version is 1.22.3.

> groff: invalid option -- k 

Indeed, this option was introduced in version 1.20.

> Werner, you had mentioned that input files should be in UTF8
> encoding?

If you want to use option `-k', yes, this is the recommended encoding
since the rest of the world is mainly using this encoding also.

> All my files right now are in simple ASCII text.  I can’t see why
> UTF8 encoding would make a difference to just one character out of
> multiple thousands.  Can you clarify?

Well, groff is restricted 8bit.  The quote character ’, U+2019, is
represented as *three* bytes in UTF-8, namely 0xE2 0x80 0x99, and
since groff doesn't let you use character 0x80, you would (a) get an
error, and (b) even it were a valid input character, it would lead to
strange output.

> Unfortunately, with El Capitan in the picture, I have no working
> PostScript viewer. [...]

It sounds like you are very familiar with the command line interface,
so I strongly suggest that you set up homebrew:

This immediately gives you access to thousands of packages (in most
recent versions), including mc, ghostscript, groff, and many others.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]