[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Package Definition Place

From: John Darrington
Subject: Re: Package Definition Place
Date: Sat, 4 Jan 2014 23:25:41 +0100
User-agent: Mutt/1.5.21 (2010-09-15)

This is where you have to start doing some detective work and probably some 

Based on what you pasted, it looks as if CONFIG_SHELL isn't getting passed to 
the file.
Probably the zsh devs have done something wierd.

What I do at this stage is to build with the -K flag, then you can manually 
enter the build directory which
guix places in /tmp/nix-build-* and start putting in diagnostics and running 
the build manually to find out
what is going on.

Sometimes it can be painful.


On Sat, Jan 04, 2014 at 04:21:35PM -0500, Kete wrote:
     On Saturday, January 04, 2014 08:15:40 AM John Darrington wrote:
     > The example in bash.scm is over complicated.  Look at some of the 
     > in xorg.scm to see how to set configure-flags.
     That got me a little further.
        Src/../Src/ line 467: /bin/sh: No such file or directory
        Makefile:299: recipe for target 'Makemod' failed
     These are the lines around 464-470:
        if $second_stage ; then
            trap "rm -f $the_subdir/${the_makefile}; exit 1" 1 2 15
            ${CONFIG_SHELL-/bin/sh} ./config.status \
--file=$the_subdir/${the_makefile}:$the_subdir/${the_makefile}.in ||
            exit 1
     I tried with the --without-tcsetpgrp flag, but I got the same error.

PGP Public key ID: 1024D/2DE827B3 
fingerprint = 8797 A26D 0854 2EAB 0285  A290 8A67 719C 2DE8 27B3
See or any PGP keyserver for public key.

Attachment: signature.asc
Description: Digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]