[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Chrooting into GuixSD

From: Nils Gillmann
Subject: Re: Chrooting into GuixSD
Date: Thu, 14 Jun 2018 12:18:56 +0000

Thorsten Wilms transcribed 1.2K bytes:
> On 13.06.2018 10:13, Nils Gillmann wrote:
> > > > Is this ability to chroot into GuixSD worth mentioning in the manual?
> > > IMHO it is not worth to be mentioned in the manual, as it is the same as
> > > for all Linux systems.
> > Not really, since you can not*fully*  chroot a GuixSD. Some functions
> > will not work, like interacting with the daemon or what it was. Last
> > time I tried this was at least 1.5 years ago.
> You can interact with the daemon:
>   cd /path/to/guix/root
>   sudo mount --bind /dev dev
>   sudo mount --bind /proc proc
>   sudo mount --bind /sys sys
>   sudo unshare -m sudo chroot . /run/current-system/profile/bin/bash
>   source /etc/profile
>   guix-daemon --build-users-group=guixbuild &
> If you then `su` to a plain user, do `source /etc/profile` again.
> I think all of `guix pull`. `reconfigure` and `package` search, install and
> update worked here with that approach. `guix download` failed due to nss
> certificates, until I added:
>   export SSL_CERT_DIR="$HOME/.guix-profile/etc/ssl/certs"
>   export
> SSL_CERT_FILE="$HOME/.guix-profile/etc/ssl/certs/ca-certificates.crt"

Huh. Okay, cool. Thanks for documeting this at least on the mailing list :)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]