[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: how to install gnatsweb???

From: George Nawfal
Subject: Re: how to install gnatsweb???
Date: Mon, 19 Mar 2001 13:08:03 -0500


I've had this problem before.   I was missing a colon in one of the lines in 
the 'Categories' file.

Look into your gnats-db.conf file and make sure that it is correct.
Then look into the configuration files and verify that they are correct too. 
Try to restore those files to their defaults and
see if that solves your problem. It worked for me.


Wes Barris wrote:

> Hello,
> I need some help installing gnatsweb.  I am trying to do this on a
> new Redhat 7 (Linux) system.  I have tried installing gnats via rpm
> (the prefered method), cvs (as described on
>, and finally, building manually (using
> configure, make, etc.).  It seems that gnats itself is working.  I can
> use either send-pr or query-pr and all is well.
> I can't get gnatsweb-2.7beta to work with any of these installations.
> It can't be that hard.  Others use it, right?  The INSTALL file that
> comes with gnatsweb says:
> 1) install gnatsd -- Done.
> 2) configure host access -- Done.
> 3) gnats/web servers on same hose -- Skip.
> 4) line 1 of -- Done.
> 5) make test USERNAME=anon PASSWORD=pw DATABASE=db_alias
> What is the "db_alias"?  This is the first I have seen it mentioned.
> Here is what I tried:
> address@hidden make test USERNAME=wes PASSWORD=test DATABASE=gnats-adm
> perl
> Content-type: text/html
> <H1>Software error:</H1>
> <PRE>Can't call method &quot;header&quot; on an undefined value at 
> line 2117, &lt;SOCK&gt; line 1.
> </PRE>
> <P>
> For help, please send mail to this site's webmaster, giving this error message
> and the time and date of the error.
> [Mon Mar 19 10:13:54 2001] Can't call method "header" on an 
> undefined value at line 2117, <SOCK> line 1.
> connect...........................................FAIL
> make: *** [test] Error 255
> address@hidden
> Would someone please please please tell me what I am missing?  Others
> must get this error too.  I have followed all of the instructions
> as far as I can tell.  What do others do to get gnatsweb to work???
> When I try to access from the web, it prompts me for
> a username and password, but the database selection box is empty.
> I have attached a very small gif showing what it looks like.
> -----------------------------------------------------------------------
> Wes Barris                                            address@hidden
> Network Computing Services, Inc.                           612.626.8090
> -----------------------------------------------------------------------
> Today's fortune: It is easier to fight for one's principles than to
> live up to them.
>   ------------------------------------------------------------------------
>                    Name: gnatsweb.gif
>    gnatsweb.gif    Type: GIF Image (image/gif)
>                Encoding: base64

reply via email to

[Prev in Thread] Current Thread [Next in Thread]