[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Loading local .emacs from remote machine

From: Kevin Rodgers
Subject: Re: Loading local .emacs from remote machine
Date: Tue, 04 Feb 2003 16:30:12 -0700
User-agent: Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv: Gecko/20020406 Netscape6/6.2.2 wrote:

Kai Großjohann at 18:30 (UTC+0100) on Tue, 4 Feb 2003 said:
= But the main problem is that tramp-shell-prompt-pattern is not
= supposed to be a list.  It's supposed to be a string.

A string in elisp must be some really strange thing.

(add-to-list 'tramp-shell-prompt-pattern "abc")

also gives the same error.  It seems that everything and anything I put into
the third arg is a listp.  It's a shame elisp is so obtuse.  I'd like to learn
it so's to do some helpful work on emacs.  Several times I've tried to do
simple things in elisp, following books and tutorials, but never had any
progress with it.  Maybe I need to be dyslexic.  :)

Emacs Lisp is not Tcl, and a string is not a list.

(setq tramp-shell-prompt-pattern
     (concat tramp-shell-prompt-pattern "\\|abc"))

<a href="mailto:&lt;kevin.rodgers&#64;;";>Kevin Rodgers</a>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]