[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Trying to install Guix System on a nonfree computer, the system frez

From: pelzflorian (Florian Pelz)
Subject: Re: Trying to install Guix System on a nonfree computer, the system frezees at booting, bug?
Date: Wed, 24 Jul 2019 08:15:33 +0200
User-agent: NeoMutt/20180716

On Wed, Jul 24, 2019 at 02:11:17AM +0200, Jan wrote:
> The system
> initialized correctly, but the same thing happens while trying to boot
> into the recently installed system (removing gdm didn't help).

Hmm I am sorry that it did not help.  You could try pressing e in GRUB
and adding “modprobe.blacklist=radeon modprobe.blacklist=amdgpu” to
the end of the linux line.

> I copied
> the whole /var/log folder so I'm attaching zip-compressed folder below.

/var/log/messages looks normal to me.

/var/log/messages shows xorg-server-vt8 started at
> Jul 24 03:28:56 localhost shepherd[1]: Service xorg-server-vt8 has
> been started.
so you waited for 90 seconds until you pressed Sysrq+E or Sysrq+I or
something at:
> Jul 24 03:30:26 localhost vmunix: [   97.542387] sysrq: Terminate All Tasks

If everything had worked, you should have seen SLIM.

/var/log/Xorg.0.log shows that no working graphics driver was found.
However, since /var/log/messages looks normal, I suppose this is an
old log file (?).

Has booting (not necessarily installing) an official Debian USB
installer (i.e. without nonfree firmware) or another libre distro
worked previously?

> And also a strange thing happened - don't know if it's related, but
> after switching my system to "UEFI mode" screen resolution using
> linux-libre, which was really low, now changed normal (as on systems
> with blobs loaded).

I see this wrong resolution too when running the installer in old BIOS
mode.  Your config shows grub-efi-bootloader, so I suppose it can only
boot in UEFI mode (?).  Maybe not booting in UEFI mode runs a wrong
bootloader (?).


reply via email to

[Prev in Thread] Current Thread [Next in Thread]