[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Trying to install Guix System on a nonfree computer, the system frez

From: Jan
Subject: Re: Trying to install Guix System on a nonfree computer, the system frezees at booting, bug?
Date: Wed, 24 Jul 2019 12:53:34 +0200

>You could try pressing e in GRUB
>and adding “modprobe.blacklist=radeon modprobe.blacklist=amdgpu” to
>the end of the linux line.
This one works, but without GUI, probably because I forgot to install
any WM/DE, but something seems to be running on tty7 and tty8, so I'm
assuming it's slim-service.

>/var/log/messages looks normal to me.
No way, even if it looks on this partition I tried only installing Guix
System and it never worked.

>so you waited for 90 seconds until you pressed Sysrq+E or Sysrq+I or
>something at:
>> Jul 24 03:30:26 localhost vmunix: [   97.542387] sysrq: Terminate All
>> Tasks
Yes, the system didn't respond at all - i couldn't even switch to
another tty, so Alt+SysRq+B was the only thing working, but sometimes i
had to hard reset the computer, because even this didn't work.

>If everything had worked, you should have seen SLIM.
Everything I saw was a frozen console, even the cursor wasn't blinking.

>However, since /var/log/messages looks normal, I suppose this is an
>old log file (?).
The partition was formatted once, but as I said before, only Guix
System ran on this partition and it never worked, so that's how the log
looks like, when I can't do anything.

>Has booting (not necessarily installing) an official Debian USB
>installer (i.e. without nonfree firmware) or another libre distro
>worked previously?
I tried installing Trisquel 8.0 to check if this is a bug in the
linux-libre kernel, but it even stopped working during installation
time. On the other hand installing Devuan works and it boots from the
SSD (if Devuan's installer is the same as Debian's, then it works).
But I can try installing Debian if it is necessary.

>Maybe not booting in UEFI mode runs a wrong
>bootloader (?).
Anyway, even if UEFI mode is enabled, the system works only with the
GPU disabled in grub.

For me, personally this sounds like an issue with Linux and Linux-libre
generally. Once about two months my system (even when using blobs)
freezes just like during early boot of Guix System. Maybe everything
is okay with the system, except the GPU driver - the screen freezes,
but the system continues to work. It's probably a problem with Linux,
because Windows 10, on the same computer, rarely crashes (by this I
mean it rarely freezes in this particular way, because it crashes a
lot, but with a sad smile ':(').

reply via email to

[Prev in Thread] Current Thread [Next in Thread]