[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Trying to install Guix System on a nonfree computer, the system frez

From: pelzflorian (Florian Pelz)
Subject: Re: Trying to install Guix System on a nonfree computer, the system frezees at booting, bug?
Date: Wed, 24 Jul 2019 14:16:50 +0200
User-agent: NeoMutt/20180716

On Wed, Jul 24, 2019 at 12:53:34PM +0200, Jan wrote:
> >You could try pressing e in GRUB
> >and adding “modprobe.blacklist=radeon modprobe.blacklist=amdgpu” to
> >the end of the linux line.
> This one works, but without GUI, probably because I forgot to install
> any WM/DE, but something seems to be running on tty7 and tty8, so I'm
> assuming it's slim-service.

Yes, maybe you may need to add (service gnome-desktop-service-type) or
another DE/WM for SLIM to work.

You probably should use UEFI mode.

The virtual console without graphics only is visible and not frozen
with “modprobe.blacklist=radeon modprobe.blacklist=amdgpu” (I do not
know which of the two modprobe.blacklist is necessary for you, one of
them should be enough).  Maybe you do not need the virtual console
though, if Xorg worked.  Note that only the display output is frozen,
but the keyboard works.

I suppose no graphics driver matches what the Xorg server expects,
therefore Xorg graphics do not work and the system remains on the
invisible virtual console.  But maybe Xorg graphics do work a little
and you just need to press some keys or log in blindly with username
and password?  Note that for me I initially had garbled graphics on my
non-Ryzen AMD GPU.

It is strange that xorg-server appears started in the log even though
it fails.  Perhaps just to be sure you need to remove
/var/log/Xorg.0.log from a previous Guix System boot and after
removing reboot and then look if there are fatal (EE) lines in
/var/log/Xorg.0.log, but maybe xorg-server being logged as running is
also a quirk of xorg-server.

> >Has booting (not necessarily installing) an official Debian USB
> >installer (i.e. without nonfree firmware) or another libre distro
> >worked previously?
> I tried installing Trisquel 8.0 to check if this is a bug in the
> linux-libre kernel, but it even stopped working during installation
> time. On the other hand installing Devuan works and it boots from the
> SSD (if Devuan's installer is the same as Debian's, then it works).
> But I can try installing Debian if it is necessary.

You do not need to install, it is enough to use a live image or a
GTK-based install image.

Devuan apparently ships non-free firmware with its installer.

Trisquel not working makes it seem like linux-libre does not support a
graphics driver for your GPU.  Maybe Debian works because it uses a
different kernel configuration, you could try.  If Debian works, then
Guix System could be made to work.

> >Maybe not booting in UEFI mode runs a wrong
> >bootloader (?).
> Anyway, even if UEFI mode is enabled, the system works only with the
> GPU disabled in grub.

You will certainly never have 3d-accelerated GPU output when using
linux-libre anyway.  You should have unaccelerated output though.

> For me, personally this sounds like an issue with Linux and Linux-libre
> generally. Once about two months my system (even when using blobs)
> freezes just like during early boot of Guix System. Maybe everything
> is okay with the system, except the GPU driver - the screen freezes,
> but the system continues to work. It's probably a problem with Linux,
> because Windows 10, on the same computer, rarely crashes (by this I
> mean it rarely freezes in this particular way, because it crashes a
> lot, but with a sad smile ':(').

I find various news reports on Duckduckgo about Ryzen systems having
problems with the Linux kernel.  The Linux-libre kernel on some AMD
systems cannot run the open-source AMD driver because it requires
non-free firmware.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]