[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

gnuplot no longer works

From: Dushan Mitrovich
Subject: gnuplot no longer works
Date: Sun, 17 Feb 2008 12:41:43 -0700
User-agent: VSoup v1.2.9.48Beta [OS/2]

I'm using Octave 3.0 under Mac OSX and have also installed gnuplot 4.2.2
that was included in the package.  After the initial install, gnuplot
displayed the plots as expected.

About a month ago, on the advice of AppleCare Support to try to fix an-
other, unrelated problem (getting FTP transfers to work), I did a so-called
'archive-install'.  After that, not only did the FTP problem persist, but
I've been discovering a number of other imporatnt things that no longer
worked, e.g. printing, and now gnuplot.  Here's what happens.

I've re-installed Xcode, X11, and AquaTerm, and also gnuplot.  To test
it out I invoked gnuplot by itself, with out going thru Octave.  First I
opened AquaTerm, then gnuplot, and tried to plot the sine function using

  => exec '/Applications/'
          G N U P L O T
          Version 4.2 patchlevel 2
          last modified 31 Aug 2007
          System: Darwin 8.11.1
          Copyright (C) 1986 - 1993, 1998, 2004, 2007
          Thomas Williams, Colin Kelley and many others
          Type `help` to access the on-line reference manual.
          The gnuplot FAQ is available from
          Send bug reports and suggestions to 
  Terminal type set to 'aqua'
  gnuplot> plot sin(x)

This produced exactly nothing, not even an error message.  So I tried X11:

  gnuplot> set terminal x11
  Terminal type set to 'x11'
  Options are '0'
  Expected X11 driver: /tmp/gnuplot-i386/libexec/gnuplot/4.2/gnuplot_x11
  Exec failed: No such file or directory
  See 'help x11' for more details

  gnuplot> plot sin(x)
  Expected X11 driver: /tmp/gnuplot-i386/libexec/gnuplot/4.2/gnuplot_x11
  Exec failed: No such file or directory
  See 'help x11' for more details


Unsurprizingly, this also produced nothing beyond the error message.
The '/tmp' directory does not contain 'gnuplot-i386', but I did find
'gnuplot_x11' in two places:

    .opt/local/libexec/gnuplot/4.0             <-- call this 'locA'

I'm out of ideas what to try next.  Suggestions would be most appreciated.

- Dushan Mitrovich

reply via email to

[Prev in Thread] Current Thread [Next in Thread]