[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: gnuplot no longer works

From: Dushan Mitrovich
Subject: Re: gnuplot no longer works
Date: Wed, 20 Feb 2008 10:59:10 -0700
User-agent: VSoup v1.2.9.48Beta [OS/2]

Thomas Treichl <address@hidden> wrote:
>Dushan Mitrovich schrieb:
>> I'm using Octave 3.0 under Mac OSX and have also installed gnuplot 4.2.2
>> that was included in the package.  After the initial install, gnuplot
>> displayed the plots as expected.
>> About a month ago, on the advice of AppleCare Support to try to fix an-
>> other, unrelated problem (getting FTP transfers to work), I did a so-
>> called 'archive-install'.  After that, not only did the FTP problem
>> persist, but I've been discovering a number of other important things
>> that no longer worked, e.g. printing, and now gnuplot.  Here's what
>> happens.
>> I've re-installed Xcode, X11, and AquaTerm, and also gnuplot.  To test
>> it out I invoked gnuplot by itself, with out going thru Octave.  First I
>> opened AquaTerm, then gnuplot, and tried to plot the sine function using
>> 'aqua'.
> I don't know what is going wrong on your Mac now.  However,
> brings its own AquaTerm.framework that should be started automatically
> when needed by  It is placed in
>    /Applications/
> Try not to startup another AquaTerm manually that might either be buggy
> or version incompatible or whatever.  One idea would be to completely
> remove from your Applications folder
>    rm -rf /Applications/
> and then reinstall that one again.  Make sure that you have quit the man-
> ually started AquaTerm (wherever it comes from) and then try again.  If
> this all doesn't help then a switch to X11 will.  Therefore you need to
>    export GNUTERM=x11 # watch out lower case letter x
> *before* you startup or put the 'export' line into your
> ~/.profile file so that it will be found everytime you launch
> The curious thing is that cannot be connected correctly *after*
> you already started  You can also try to set a line 'export
> GNUTERM=aqua' in your .profile file - maybe this helps for you?!
> Let us know if something helps for you...

Thomas, I spent some time yesterday following your suggestions and experi-

# checked that AquaTerm.framework is where it is supposed to be; it is

# quit the manually started AquaTerm

# removed, then re-installed it from gnuplot-4.2.2-i386.dmg
  (from Octave's Extras)

# started Octave and gave it the instruction
    x = 0 : 0.1 : 6.3;  plot(sin(x))
  The AquaTerm menu came up as expected, and Octave produced a new prompt;
  That's it - no plot, and no error message.  AquaTerm's menu entry 'About
  AquaTerm' announced version 1.0.1 from sourceforge.  Under 'File' all
  the items are gray except Open Recent, which has a gray Clear Menu.  And
  under 'Help' the item Testview produces nothing,

# quit Octave; in Terminal gave instruction  "export GNUTERM=x11"

# restarted Octave and tried same plot again; same results: no error mes-
  sage and no plot

# logged out and logged back in under vanilla account 'Test'; same results
  except that now Aquaterm's 'Testview' does produce a sample window

# there are three versions of AquaTerm on my system: in /Applications,
  in /Library, and within (the one you refer to above).  When
  examined with a binary file viewer, only the first one, in /Applications,
  contains the version number 1.0.1; the other two have no such number.
  So gnuplot seems to be invoking the wrong AquaTerm.  Also, after the in-
  struction "export GNUTERM=x11", a plotting request from Octave doesn't
  invoke X11 in any form (I thought earlier, when plotting did work, X11
  did show up as an open app with its own menu - but this may be my imagi-
  nation).  This all hints that maybe Octave is missing some essential
  link it needs to be able to use one of the plotting interfaces.

Can you suggest other things I should try further to isolate my problem?

- Dushan

reply via email to

[Prev in Thread] Current Thread [Next in Thread]