[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [libmicrohttpd] Building libmicrohttpd-0.9.55 on RHEL5

From: Svein Olav Bjerkeset
Subject: Re: [libmicrohttpd] Building libmicrohttpd-0.9.55 on RHEL5
Date: Sat, 30 Sep 2017 11:54:43 +0200
User-agent: Roundcube Webmail/1.2.1

Den 2017-09-29 22:25, skrev Evgeny Grin:
On 29.09.2017 23:02, Svein Olav Bjerkeset wrote:
If you could share scripts for rebuild or exact build steps - I'll try
to reproduce.

Build script is attached. It requires the source files to be unpacked in
the build root.

I just tried it on a new CentOS 5 vm, and now it works, even with
3.6.0/2.7.1. In other words, I am unable to reproduce the error on this vm.

Did your RHEL5 machine has all latest 5-series updates, including latest
RHEL5 kernel?

Or may be one of rebuilt libs was compiled against new lib, but have
missing '-rpath' so used at runtime with wrong lib? This could explain
broken data and crashes.

The RHEL5 server is a vm on a VMware farm. The ESX'es has Intel CPUs, but I am not sure which model. It has all the latest updates, even extended lifecycle support from RedHat.

The CentOS5 vm is on my private server with AMD CPU. It has the latest CentOS5 updates.

Best regard,
Svein Olav Bjerkeset

reply via email to

[Prev in Thread] Current Thread [Next in Thread]