[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Texinfo - manual line breaks in URLs?

From: Michael Käppler
Subject: Re: Texinfo - manual line breaks in URLs?
Date: Thu, 18 Jun 2020 15:00:38 +0200
User-agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:68.0) Gecko/20100101 Thunderbird/68.9.0

Am 17.06.2020 um 16:44 schrieb David Kastrup:
Michael Käppler <> writes:

Am 11.06.2020 um 15:22 schrieb Werner LEMBERG:
I can prepare a version of the docs with all occurences of '@/'
removed and '@urefbreakstyle before' set, so that everyone can
compare and build an opinion on this.
Great, thanks in advance.  I suggest that you use the `texinfo.tex`
file directly from the 'texinfo' git repository so that we test the
most recent version.

This turned out to be difficult.
As a first step I tried to upgrade texinfo.tex to current master
of the official Texinfo git repo. This broke 'make doc'
with a XeTeX error, handed over by 'texi2pdf' with the pretty
useless message: "XeTeX exited with bad exit status"
This happened just after finishing the first XeTeX pass.

I appended various options to texi2pdf to make the output
more verbose, but I did not get useful output regarding
the XeTeX termination.

Bisecting yielded that the first texinfo commit that introduced
the error is
Uh oh.  This looks like it introduces (modifies?) a command named
@seealso but it would appear that we define our own version of it.
Yes, that is the problem with the most recent texinfo.tex.
Regarding the missing index I did a bit of research. It is clear
that something changed with
regarding index handling but I do not understand the TeX syntax to
figure out how it did exactly change.
What I do understand is that the index entries, e.g. from
that I tested are now
like @index{foo}, not \index{foo} as previously.

All following steps were tried with texinfo.tex from

I can reproduce the missing index on top of a doc build if I compile
manually with texi2pdf
cd ~/lilypond/build/Documentation/out-www
rm learning.{aux,cp,cps,dep,ky,kys,log,pdf,pdfmark,tmp.*,toc}
TEXINPUTS=~/lilypond/tex:: texi2pdf -V learning.texi

However, with manual xetex/texindex steps the index was generated fine:
$XETEX learning.texi
texindex learning.??
$XETEX learning.texi
texindex learning.??
$XETEX learning.texi

as described in

What seems most likely to me is that the indices are generated
correctly, but texi2pdf refuses to generate
the sorted versions.
If I call texi2pdf --debug I do not see any invocations of 'texindex'.
May it be that texi2pdf does not call texindex but use an inlined
sorting mechanism that
cannot cope with @index, only \index? I can try if updating texi2pdf
cures the problem.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]