[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[lmi] synchronizing wx and lmi for production

From: Boutin, Wendy
Subject: [lmi] synchronizing wx and lmi for production
Date: Fri, 12 Aug 2005 16:00:58 -0400

[This is mostly directed to Vadim, but I posted here to make
future searches on already-made-decisions easier.]

In an attempt to make synchronizing lmi and wx easier, I'd like
to solicit your input on a few things I've observed along the way.

As you've made wx changes for us I've managed to test them on the
fly using cvs. I've run into occasional building problems that
suggest wx's cvs might not be as stable as a formal release for
use in production with lmi. I've worked through a few problems
(detailed below), but would like your opinion on where to go from

I'm behind a firewall in the office, so when I try to checkout new
wx code my issues seem to stem from that firewall not liking 'pserver';
I don't experience this on my own computer (where I actually have
control over my system). If you're interested, my checkout output says:
  [hidden] /c/downloads
  $ cvs -d :pserver:address@hidden:/pack/cvsroots/wxwidgets checkout wxWidgets
  cvs [checkout aborted]: connect to cvs.wxwidgets.org:2401 failed:
  Attempt to connect timed out without establishing a connection
and when I searched the web for a possible solution, I came up with this
  | If your filewall already allows RSH (unlikely) or SSH (quite
  | possibly) connections, you can use one of them with the :ext:
  | connection method instead of using pserver.
which seemed viable because I can checkout code from lmi's cvs using
ssh. However, that wasn't successful either:
  [hidden] /c/downloads
  $ cvs -d :ext:address@hidden:/pack/cvsroots/wxwidgets checkout wxWidgets
  address@hidden's password: [typed 'anoncvs']
  Permission denied, please try again.
  address@hidden's password: [typed 'anoncvs' again]
  Permission denied, please try again.
  address@hidden's password: [typed 'anoncvs' again]
  Received disconnect from 2: Too many authentication failures 
for anoncvs
  cvs [checkout aborted]: end of file from server (consult above messages if 

I'm sure the above failure isn't related to this recent problem with
because I had it before that bug surfaced and I've tried it since the
bug was fixed, just to be sure. I have grave doubts about successfully
getting through the firewall problem in the office, especially if that
means getting our administrators involved. Have you come across this
problem before?

At times I've resorted to using wx's nightly tarballs for testing.
The problem with that method is the archives are only available on
the server for seven days. In our business environment, it takes
longer than those seven days to test, accept, and then release your
changes to others for a formal upgrade and synchronization with lmi.
Although, the bigger problem is not having a stable URL that can be
used in our setup automation. Is it possible to have the tested
nightly archive publicly preserved somewhere so we can always access
it? Maybe we only ever need to keep *the* synchronized archive there.
So far, that's the best solution I can find, but do you have any
other suggestions? Is this even feasible from your perspective?

While we're on the subject, I've often just used the most recent cvs
when testing your enhancements for us--sometimes its been days before
I got to the testing. Should I be using cvs as of some specific date
after you've fixed something? Again, if that date is beyond the
duration of the daily builds, I'm probably out of luck if I'm testing
in the office.

That aside, I've been attempting to build wx using ./configure && make
in msys in lieu of manually modifying setup.h. Unfortunately, the usual
libraries I expect aren't all there, so I'm guessing I've probably
missed something. I'm pretty sure I correctly translated the settings
I want on the command line, but I don't really know what else I may
need to do to get what I need. I usually modify setup.h in this way:
  /include/wx/msw[0]$diff -u0 setup0.h setup.h
  --- setup0.h    Sun Feb 20 17:05:07 2005
  +++ setup.h     Wed Mar 23 12:11:20 2005
  @@ -47 +47 @@
  -#define WXWIN_COMPATIBILITY_2_4 1
  +#define WXWIN_COMPATIBILITY_2_4 0
  @@ -218 +218 @@
  -#define wxUSE_STL 0
  +#define wxUSE_STL 1
  @@ -261 +261 @@
  -#define wxUSE_THREADS 1
  +#define wxUSE_THREADS 0
  @@ -267 +267 @@
  -#define wxUSE_STD_IOSTREAM  0
  +#define wxUSE_STD_IOSTREAM  1
  @@ -418 +418 @@
  -#define wxUSE_APPLE_IEEE          1
  +#define wxUSE_APPLE_IEEE          0
  @@ -463 +463 @@
  -#define wxUSE_REGEX       1
  +#define wxUSE_REGEX       0
  @@ -927 +927 @@
  -#define wxUSE_RESOURCES   0
  +#define wxUSE_RESOURCES   1
  @@ -995 +995 @@
  -#define wxUSE_IOSTREAMH     1
  +#define wxUSE_IOSTREAMH     0
  @@ -1016 +1016 @@
  -#define wxUSE_LIBJPEG       1
  +#define wxUSE_LIBJPEG       0
  @@ -1019 +1019 @@
  -#define wxUSE_LIBTIFF       1
  +#define wxUSE_LIBTIFF       0
  @@ -1022 +1022 @@
  -#define wxUSE_GIF           1
  +#define wxUSE_GIF           0

and make it this way:
  make --keep-going -f makefile.gcc SHARED=1 MONOLITHIC=1 USE_THREADS=0 \

which results in these libraries:
  [hidden] /c/downloads/wxWidgets-2.5.4/lib/gcc_dll
  $ ls
  libwxexpatd.a  libwxpngd.a    libwxzlibd.a
  libwxjpegd.a   libwxregexd.a  mswd
  libwxmsw25d.a  libwxtiffd.a   wxmsw254d_gcc_custom.dll

Although, lmi only relies on 'libwxmsw25d.a' and 'wxmsw254d_gcc_custom.dll'.

I translated my settings to the command line in this way:
  [hidden] /c/Temp/WxWidgets/build-msys-again
  $ ../configure --disable-compat24 --enable-stl --disable-threads \
  --enable-std_iostreams --disable-apple_ieee --disable-mediactrl \
  --disable-std_iostreams --without-libjpeg --without-libtiff \
  --disable-gif --enable-shared --enable-monolithic \
  CXXFLAGS="-DNO_GCC_PRAGMA" >>wxmsys-configurations

I got these warnings, but they didn't seem detrimental:
  configure: WARNING: system regex library not found, will use built-in instead
  configure: WARNING: zlib library not found or too old, will use built-in 
  configure: WARNING: system png library not found or too old, will use 
built-in instead
  configure: WARNING: system expat library not found, will use built-in instead
  configure: WARNING: ddraw.h or multimon.h not found; disabling wxDisplay
  configure: WARNING: ddraw.h or multimon.h not found; disabling wxDisplay
  configure: WARNING: Catching fatal exceptions not currently supported on this 
system, wxApp::OnFatalException will not be called

and made it this way:
  make >>buildlog 2>&1

but that resulted in only these libraries:
  [hidden] /c/downloads/wxWidgets/build-msys/lib
  $ ls
  libwxexpat-2.6.a  libwxpng-2.6.a  libwxregex-2.6.a  libwxzlib-2.6.a  wx

I expected to get exactly the same libraries because I thought I was
building it with the same options. I compared setup files from both methods
and the settings were identical in both; that gave me some assurance that
I translated the settings correctly. Do you have any ideas that could help
me get the two real important libraries using this method?

This e-mail transmission may contain information that is proprietary, 
privileged and/or confidential and is intended exclusively for the person(s) to 
whom it is addressed. Any use, copying, retention or disclosure by any person 
other than the intended recipient or the intended recipient's designees is 
strictly prohibited. If you are not the intended recipient or their designee, 
please notify the sender immediately by return e-mail and delete all copies. 


reply via email to

[Prev in Thread] Current Thread [Next in Thread]