[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: export entire data table

From: Ben Pfaff
Subject: Re: export entire data table
Date: Tue, 01 Nov 2011 22:10:05 -0700
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.2 (gnu/linux)

Jessie Braden <address@hidden> writes:

> I tried exporting the data table as a .por file but I get an error. It says,
> “error: creating temporary file C:\Program Files\PSPP\test;.por.tmpOOIp1n:
> Permission denied.”
> We have to have an admin login to install programs so I wonder if I can’t even
> write to the C:\Program Files folder. Any thoughts?  I also tried going
> through the syntax editor and doing EXPORT (calling it a .csv file) but I got
> the same error.

What directory did you tell PSPPIRE to put the file into?  If it
isn't C:\Program Files\PSPP, then this sounds like a bug.

What syntax did you use?

> Somehow, though, the other day I did manage to create a .por file. However it
> was really small and came through totally jumbled when I tried to open it in
> Excel using the Text Import Wizard. Using Excel 2010 and PSPPIRE
> 0.7.5-g70514b.

A .por file contains text but it isn't plain text.  I wouldn't
expect that it would import sensibly in anything that doesn't
specifically understand the .por format.

> Finally I tried selecting the whole table and simply Copy->Paste. This is
> almost works except I consistently lose about 8 rows of data  (from the middle
> of my dataset). And the headers don’t copy over. Our dataset only has 145 rows
> of data so far but we have 427 variables (huge survey). It won’t let me Copy
> from Variable View (I could grab the column headers that way and transpose in
> Excel).

Hmm.  I tried a bunch of copy and paste of large table data just
now (over 900 rows, hundreds of columns) and couldn't reproduce a
problem like that.  A few programs that I pasted into did lose
some rows, but always at the end.  I didn't have any trouble with
the headers.

I think that your best bet is probably to export the output to
.csv format.  This works OK for me with the latest PSPPIRE; just
select CSV format from File|Export in the Output window.

You'll probably want to upgrade from 0.7.5 to the latest version
though.  I don't know where to get an up-to-the-minute latest
version for Windows.

My test platform is GNU/Linux.  I hear that there are Windows
specific bugs; perhaps this is one.
Ben Pfaff

reply via email to

[Prev in Thread] Current Thread [Next in Thread]