[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: -r option

From: Jeff Powell
Subject: RE: -r option
Date: Mon, 17 Mar 2003 13:57:07 -0800

No, it does not work if I run it from te commandline.  No effect.  the ps 
output looks like this:
root     19923  0.0  0.3 10860  948 pts/2    S    13:55   0:00 spamass-milter 
-p /var/run/spamass.sock -f -d 1 -D -u nobody -r 9

However, when I run this from the cmd line, it says the -D is invalid (I did 
patch it).
So, it's got all of its options from the file but is not applying them.

        -----Original Message----- 
        From: Dan Nelson [mailto:address@hidden 
        Sent: Mon 3/17/2003 1:44 PM 
        To: Jeff Powell 
        Cc: address@hidden; address@hidden 
        Subject: Re: -r option

        In the last episode (Mar 17), Jeff Powell said:
        > On further inspection the milter does not appear to be applying ANY 
of the options in the /etc/sysconfig/spamass-milter file.  It is definitely 
reading the file; I tried using Nigel Horne's -D option (BEFORE adding the 
patch) and when I tried to restart spamass-milter it complained (correctly) 
that -D was an invalid option.  I then patched and reinstalled spamass-milter 
with the -D enabled.  This time, it did not complain when I tried the -D option.
        > So it appears to be reading the file, but not applying any of the 
        > The -D option has no effect.
        > The -d (debug) option has no effect.
        > The -r option has no effect.
        After you start the service with the script, what is the output of "ps
        ax | grep spamass-milter"?  You should see all your commandline args
        Does it work if you run spamass-milter directly from the commandline?
                Dan Nelson

reply via email to

[Prev in Thread] Current Thread [Next in Thread]