[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Tramp loads files but gets stuck always until C-g pressed.....with e

From: Kai Großjohann
Subject: Re: Tramp loads files but gets stuck always until C-g pressed.....with every shell tried and prompt
Date: Mon, 26 Jan 2015 21:33:23 +0100

First of all, Tramp sends commands to the remote end to set up the shell, and it is possible to add setting HGPLAIN to that list of commands. I think that's what Michael meant.

Secondly, Tramp sets TERM=dumb and so the shell init file (.zshrc or .bashrc or the like) can check that to set HGPLAIN=1. Presumably, on a dumb terminal, invoking a pager does not make sense.


On 26 Jan 2015, at 17:59, Christian Seberino wrote:

I can confirm

export HGPLAIN=1

fixes the problem on Ubuntu 14.04 with Emacs 24.3 and zsh.
If someone wants a way to set this on a per platform basis they may do something like this..

if [[ "$HOST" != "desktop" ]] then
export HGPLAIN=1

Do you know of a way to only set this for Emacs in case someone doesn't want plain
hg diffs? (Otherwise they'll probably have to keep setting and unsetting this far I'm guessing.)


On 01/26/2015 03:39 AM, Michael Albinus wrote:

Christian Seberino address@hidden writes:

Hi Christian,

I'll investigate if you want since I'd like to help improve Tramp and
don't know if remote hg status
will be helpful in future....I tried to reproduce the problem by
pasting the commands in
a remote zsh shell but it worked fine...

Thanks for this. However, I believe it is not the command but (likely)
hg not working pretty well with the terminal Tramp emulates.

Chances are good that it is fixed already in Emacs 25.0.50, the
development version. There was a change to always set HGPLAIN=1 when
working with Mercury. If you want, you could check it.


Best regards, Michael.

Tramp-devel mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]