[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Tramp 2.0.36 on Red Hat 8.0

From: Charles Curley
Subject: Re: Tramp 2.0.36 on Red Hat 8.0
Date: Wed, 30 Jul 2003 07:06:49 -0600
User-agent: Mutt/1.4.1i

Again, please CC me as I am not on the list.

On Wed, Jul 30, 2003 at 09:03:26AM +0200, Michael Albinus wrote:
> Charles Curley <address@hidden> writes:
> Hi,
> > I just installed Tramp 2.0.36 on Red Hat 8.0 (GNU Emacs 21.2.1) as
> > updated. Everything went very well; thank you all for a wonderful
> > product. I just used it to edit some files on a machine that I
> > previously couldn't use tramp on.
> >
> > A few notes:
> >
> > * The folks at Red Hat tend to move files around on you. RH 8.0 stores
> >   info in /usr/share/info/, and site-lisp at
> >   /usr/share/emacs/site-lisp. This means that using the same prefix
> >   for info and elisp doesn't work. I solved the problem by using mv to
> >   get the info file where I wanted it. Also, BTW, I compressed it, so
> >   that it is now You might want to have two .configure
> >   variables for pathology, one for the info directory, the other for
> >   the site-lisp directory, rather than the current --prefix.
> Hmm, I will try to extend configure a little bit next days. 'Cause I
> don't run RH by myself, I'ld like to (mis)use you as tester. Is it OK?

Sure, keep me posted off-list.

> > * The installation did not integrate the info page into
> >   /usr/share/info/dir. I guess that problem will go away when Emacs
> >   21.4 comes out. This is a minor issue as one can always use "info -f
> >   /usr/share/info/" or equivalent.
> See the info at "(tramp)Load paths".

?? I read the information on load paths in the tramp file INSTALL, but
don't see anything there about editing dir.

> > * So far I have not seen any problems saving files with RH 8.0, but I
> >   haven't tried saving any large files. For this purpose, what's a
> >   large file? Or is that issue
> >   (
> >   solved?
> "Large" files seem to start upper 500 Bytes. I wouldn't say the
> problem is solved, because there's no automatism to detect on which
> systems it is necessary to set `tramp-chunksize'. Tramp tries to keep
> a "blacklist" of system types where it is necessary. This list is very
> short until now: just "hpux" found its way there. If you know other
> candidates for that list, please report. A simple test you can find
> with "C-h v tramp-chunksize".

Oh, well. I exercised tramp with several files of 50K size residing on
several different computers, and had no problems.

I evaluated the elisp code in the documentation for tramp-chunksize,
and got:

Bytes sent: 1000        Bytes received: 1000
"Bytes sent: 1000       Bytes received: 1000"

I don't see anything in the documentation that says what to make of
whatever results you get. Nothing that says, "If you got this result,
do X, if you got that result, do Y."

From what you just said, I conjecture that if that elisp had returned
a different result for bytes sent and received, that one should set
tramp-chunksize to the received value or perhaps a bit lower.

> Best regards, Michael.


Charles Curley                  /"\    ASCII Ribbon Campaign
Looking for fine software       \ /    Respect for open standards
and/or writing?                  X     No HTML/RTF in email    / \    No M$ Word docs in email

Key fingerprint = CE5C 6645 A45A 64E4 94C0  809C FFF6 4C48 4ECD DFDB

Attachment: pgpa8FjaCP8gc.pgp
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]