[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Problem with linux

From: John Clark
Subject: Re: [Discuss-gnuradio] Problem with linux
Date: Wed, 24 Jan 2007 17:50:38 -0800
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv: Gecko/20060910 SeaMonkey/1.0.5

Matt Ettus schrieb:
John Clark wrote:
Ok,  I've been setting up a system which is based on the Linux kernel
and now have tried using the USRP device...

Well, if it worked I wouldn't be posting... the device is seen in a
2.6.17 kernel,
however, not in the

I see a dmesg output which indicates that the device is detected at
some level,
but the python script cacs on 'Unable to find USRP #0', even thought when
I use USBVIEW it is seen and correctly identified as the USRP device.

The questions are:
1) Has anyone else used or had problems with
2) What configurations, and or modules need to be in, or loaded in, to
work correctly.

Given that I see dmesg output when the device is plug in, out, or even
accessed by
the python-usrp calls, it seem that most of USB stuff is there. Are
there any options
config files, etc for 'hotplugging' that may be getting in the way?

Does it work if you run as root?  Something in udev might have gotten
messed up.

Unlike most people... I always run as root... what me worry...

A couple of items...

I'm using the debian apt-get package. Which I just did another 'apt-get install' on. I did create a 'usrp.rules' file and put it in to the /etc/udev... and when I unplug and replug the device I see an entry under /dev/bus/usb/005/... which has 'usrp' as the group name. So it looks like udev is seeing the event and creating/modifying a node at some

If I need to do a build from svn sources, I think everything is up to a usable level
outside of 'gnuradio/usrp'.

And of course it is working under the 2.6.17 kernel that is sort of my absolute last fall back

John Clark.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]